• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Unable to put certificate file

matzem

New Pleskian
Thats the error i get while trying to upload a new certificate.

"Unable to put certificate file: Unable to arrange cert file: plesk_tempnam() failed: tempnam failed:Incorrect temporary file name generated."

Any idea how to solve this issue? I tried with the FileUtils.php of http://forum.parallels.com/showthread.php?t=109603 but that seems to be PLESK 10.1 i have recently updated to 10.3.

Hope this can be solved, thanks in advance

Matze
 
Hi,

thanks for your reply.

PLESK 10.3.1 running on CentOS 5.

If there is no fix for this, maybe it is possible to include a new ssl cert directly into the database? It should be possible, to overwrite the existing blob value of the working cert inside the mysql database, isn't it? Any problems to expect? Anyone experienced with manipulating the db directly?

matze
 
Last edited:
The try to manipulate the db failed. I got openssl errors after the import. There should be a fix soon, my cert is out of date.

thanks,

matze
 
Back
Top