1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Update 9.0.1 - 9.2, can't get fastcgi file info

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Free-H, Apr 30, 2009.

  1. Free-H

    Free-H Guest


    I have a little problem... OR BIG PROBLEM.

    [root@vicky ipmitool-1.8.9]# service httpd start
    Démarrage de httpd :Syntax error on line 40 of /var/www/vhosts/xxxx/conf/httpd.include:
    can't get fastcgi file info: dynamic, errno: 2

    And google my friend return no good info...

    I unload the module and httpd is online, but no fcgi...

    Any idea ? Same problem ?
  2. superbock

    superbock Guest

    Most likely the upgrade did not update the psa-php5-configurator package. Worked for me.
  3. ali momen

    ali momen Guest

    Please Help me
    I updated 9.0.1 to 9.2.1 and i have this problem too.
  4. Michael neese

    Michael neese Guest

    when you updated, did you select the php5 option for update?
  5. ali55

    ali55 Guest

    there is not php5 option
    my php version is 5.1.6
  6. christian veraghe

    christian veraghe Guest

    I got exactly the same problem, and maybe for the same reasons (plesk update) :

    [root@xxxx /]# service httpd restart
    Stopping httpd: [FAILED]
    Starting http: Syntax error on line 59 of /var/www/vhosts/xxxx/conf/httpd.include:
    can't get fastcgi file info: dynamic, errno: 2

    The line :

    #56 : <IfModule mod_fcgid.c>
    #57 : <Files ~ (\.php)>
    #58 : SetHandler fcgid-script
    #59 : FCGIWrapper dynamic .php
    #60 : Options +ExecCGI
    #61 : allow from all
    #62 : </Files>
    #63 : </IfModule>

    The only solution I found at the moment to restart my web server is to use php as an apache module and not a FastCGI application, but as a result some features of my website don't work anymore.

    If anyone could help us...

    He is welcome !

  7. Michael neese

    Michael neese Guest

    have you tried the hot fix for fcgi issues?
  8. christian veraghe

    christian veraghe Guest

    No I didn't.

    Would you please tell me where I can find it ? I'll try as soon as I get it.
  9. Michael neese

    Michael neese Guest

    Here is the link. If you did your upgrade to 9.2 using the command line auto installer, you would have had the option to install revisions for php5 issues, and i think this would have been one of them.

    Anyway, easily reversed if doesn't work, but this may solve the issue. This is found in the Knowledge base, along with other hot fixes that have accumulated. I'm not sure if you wish turn the rewrite engine off, because that may have been fixed with the 9.2.1 update.


    let us know if this does the trick.
  10. Michael neese

    Michael neese Guest

  11. christian veraghe

    christian veraghe Guest

    Not working :/

    I was still running with plesk 9.2.1 and not plesk 9.2 as it is mentionned in this post subject, does it make a difference ?
  12. Michael neese

    Michael neese Guest

    Try using the command line installer, not through plesk interface, then re-install and be sure to select the php5 features for updating.
  13. christian veraghe

    christian veraghe Guest

    First I want to thank you Michael for trying to help us with our problem.

    But I'm completely newbie in this domain, and I'm not sure I understand your advice correctly. Maybe you could be more precise please ? :)

    Second, I want to add too that before updating plesk, my site was running with php4, and not php5, mostly because the site was made with a cms, ezpublis 3.9.3, which not support php5.
    Maybe you can see another source for our problem with this info ?

    And finally, I found this post today : http://www.1and1faq.com/forums/showthread.php?p=6176

    I tried the tip given by this guy, replacing "FCGIWrapper dynamic .php" by "FCGIWrapper /usr/bin/php-cgi .php".

    With this I succeed in restarting httpd service with fastcgi enabled for all my site but just like him, I can't run php page anymore because of an error 500.

    In /var/log/httpd/error_log I got :

    [notice] mod_fcgid: call /var/www/vhosts/xxxxx/httpdocs/index.php with wrapper /usr/bin/php-cgi
    [notice] mod_fcgid: server /var/www/vhosts/xxxxx/httpdocs/index.php(2852) started
    [notice] mod_fcgid: process /var/www/vhosts/xxxxx/httpdocs/index.php(2852) exit(communication error), terminated by calling exit(), return code: 114
  14. Michael neese

    Michael neese Guest


    I think there may be some different issues here in this thread. I am making suggestions referring to issues of upgrades and cgi/fastcgi problems with plesk 9.01 to 9.2.1.

    As far as this hack script that people are using, i don't know what that is all about and seems to be a source of errors for many. Is that a hack script or is that part of plesk?

    Did you re-install the upgrade through ssh using the installer and selecting the php5 box for upgrade? And did you try the "hotfix" for these issues.
  15. christian veraghe

    christian veraghe Guest


    Could you explain me how to use the command line installer please ? It's really confuse in my mind.

    I went there : http://www.parallels.com/download/plesk/patches/
    and I've downloaded : Plesk 9.2.1 for Linux/Unix Patches for CentOS 5.x 64 bits
    directly on my web server (in /var/temp/ directory)

    I untar the file and got mutliple directories with rpm files. But I don't know which one to use for the global installation.

    http://download1.parallels.com/Plesk/PPP9/plesk-9.2.1-for-rpm-based-os.html didn't help because it always refers to "parallels_products_installer_file_name"...

    Thank you in advance.
  16. Michael neese

    Michael neese Guest

    First you have to access your server through what is called an ssh session. If this is foreign to you, please consider your issues will be getting greater for administering your server.

    Try contacting these people about setting up your server. For $100 or so you will be really configured and working. Click on the "chat with our expert and he may help you."

    Read the article on server setup and if this is above your head better contact them.


    good luck.
  17. nikolam

    nikolam Guest

    Any resolution

    Hi Guys,

    I just updated my Plesk from 9.0 to 9.2.1 (through their own updater -- web interface) and now I have this exact same problem. If I enable FastCGI for a domain, I cannot restart apache. It gives that exact error : "can't get fastcgi file info: dynamic, errno: 2". There's gotta be a fix for this. Did anyone figure it out? I'm stumped.

    It seems that this problem would be widespread. Thanks!
  18. dash

    dash Regular Pleskian Staff Member

    Sep 26, 2007
    Likes Received:
    As I see, there are different problems with php as fast-cgi mixed here in this thread.
    Right now one of these problems is clear for me – apache server can’t be restarted:
    And the reason is that httpd.include file contains “#59 : FCGIWrapper dynamic .phpâ€
    It is definitely a bug. This line should contain php-cgi binary instead of “dynamic†word.
    As I understand this happened due to failed php configuration procedure during Parallels Plesk Panel upgrade.
    Incorrect value “dynamic†is stored in /etc/psa/psa.conf file. You should find CGI_PHP_BIN parameter in it. (On my CentOS-5 it should be: CGI_PHP_BIN /usr/bin/php-cgi)

    /usr/bin/php-cgi value depends on OS that you use. For example, on Suse 10.3 it should be /usr/bin/php-cgi5 or /usr/bin/php5-cgi on Debian
    You can set correct value for CGI_PHP_BIN manually or you can try to reconfigure php by force reinstalling of psa-php(4|5)-configurator package.
    To do so execute (on rpm based systems) rpm –force –Uhv <path to psa-php-configurator package>.
    If you use autoinstaller or web-updater this package is stored in /root/parallels/PSA_9.2.1/dist-rpm-<your_os>/contrib/ folder since upgrade. (On my CentOs-5 it is: rpm --force -Uhv /root/parallels/PSA_9.2.1/dist-rpm-CentOS-5-i386/contrib/psa-php5-configurator-1.5.1-cos5.build92090422.13.noarch.rpm)
    Check CGI_PHP_BIN value after the procedure (and check that the php binary file really exists).
    Now reconfigure apache: /usr/local/psa/admin/sbin/websrvmng –v -a

    Please post here the result.
  19. Michael neese

    Michael neese Guest

    Run the auto installer from ssh, not the plesk interface installer.

    This is the ssh command for the auto installer:


    run that and select options preferred. Make sure you select the option for php5. this should clean up the fcgi issues.
  20. nikolam

    nikolam Guest


    Thanks Michael and Dash!

    Running the autoinstaller form the shell worked. In my case it was located at:


    That installed the package: psa-php5-configurator-1.5.1-cos5.build92090422.13.noarch

    which fixed the problem.