1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Update Broke Bind?

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Superman857, Jan 23, 2011.

  1. Superman857

    Superman857 Guest

    0
     
    I'm running Plesk 10.0.1. Today, I ran a yum update to update all packages on the machine (CentOS) and it seems like it might have broken BIND, perhaps...or something else did.

    After the yum update, everything worked fine (or so I thought). However, I just noticed that the site was down and BIND was not running. I think it must have been since the update, but my web proxy at home had cached info for the domain. Tried starting it and obtained this message:

    dnsmng: Service /etc/init.d/named failed to start

    Trying to start via console provided a bit more information, regarding a zone testdude.com that didn't have records properly. Looking inside /etc/named.conf revealed that the zone was in there (not mine). Commenting it out fixes the problem and BIND starts.

    So, my question is this: where did this zone come from? I didn't add it manually or through the interface. Would it be added in during a yum update? Did Plesk do something over the last few hours to add it in? I haven't had this issue before or dealt with BIND too much in the past so I'm not sure what the default zones are or how they are updated really. I'd just like to know where it came from so that I can keep it in mind in the future and avoid sites from going down.
     
    Last edited by a moderator: Jan 23, 2011
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    $ host testdude.com
    testdude.com mail is handled by 1 inbound.testdude.com.criticalpath.net.

    Parallels has no relation to this zone.
     
  3. fogelf

    fogelf Regular Pleskian

    23
    37%
    Joined:
    Feb 10, 2010
    Messages:
    103
    Likes Received:
    0
    On rh/ce zones stored in /var/named/run-root/var, zones includes in /var/named/run-root/etc/named.conf

    For bind start with debug info U can call 'sh -x /etc/init.d/named restart'
     
Loading...