• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

updater fails for all packages

mdafforn

New Pleskian
Hello all,

When I try to use the plesk updater for any package, including the 7.5.2 base packages, I get the following error:

<many pages snipped>
Preparing for packages installation...
----- begin of output -----
Installing php-pgsql-4.3.2-psa.rh9.1.i386.rpm
error: Failed dependencies:
php = 4.3.2-psa.rh9.1 is needed by php-pgsql-4.3.2-psa.rh9.1

----- end of output -----
I tried doing:
rpm -e php-pgsql

but rpm said package not installed.

Anyone got a hint for me?

Update, I tried the following:

up2date php-pgsql

got:

Unresolvable chain of dependencies:
aspell-en-0.51-6 requires aspell >= 0.50


tried yum install php-pgsql

got:
[Errno 4] IOError: <urlopen error >
 
I finally just did a rpm -e php --force , ran the updater, then re-installed php. It worked, probably wasn't the best solution, but what the hell.
 
Back
Top