1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Upgrade to 7.5.3 fails - php-domxml

Discussion in 'Plesk for Linux - 8.x and Older' started by Malguido, May 22, 2005.

  1. Malguido

    Malguido Guest

    0
     
    Received the following report when attempting to upgrade to 7.5.3. "Installing php-domxml-4.3.8-1.1.i386.rpm
    error: Failed dependencies: php = 4.3.8-1.1 is needed by php-domxml-4.3.8-1."

    Currently running Plesk 7.5.2 on Fedora Core 1.

    rpm -q php returns "php-4.3.10-3.2"

    rpm -q php-domxml returns "package php-domxml is not installed"

    yum install php-domxml returns "....Unable to satisfy dependencies Package php-domxml needs php = 4.3.10-1.1.legacy, this is not available."

    And, unfortunately, I am not a linux guy.. Please assist.
     
  2. jabber44

    jabber44 Guest

    0
     
    I was getting the same error while trying to upgrade to 7.5.3. I finally got it to work by doing the following.

    Find php-domxml-4.3.8-1.1.i386.rpm, i think by default it will be located in /root/psa/PSA_7.5.3/FC1_std.updates/

    then i manually installed just this file with the --nodeps flag.

    rpm -Uvh --nodeps php-domxml-4.3.8-1.1.i386.rpm

    install success.

    Logged back into the control panel https://www.domain.com:8443 and proceeded to the update manager and updated to 7.5.3 with no further errors.

    Hope this helps.
     
Loading...