• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Issue Upgrade to Plesk Obsidian 18.0.29 error

signomax

New Pleskian
Hi, I get a error when try to upgrade plesk, someone can help me?
thankx

This is the log:

Installation started in background
Checking whether the package dependencies are resolved.
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libaps : Depends: plesk-libpoco-1.9.0 (>= 1.9.0) but it is not going to be installed
linux-image-generic : Depends: linux-image-4.4.0-185-generic but it is not going to be installed or
linux-image-unsigned-4.4.0-185-generic but it is not going to be installed
Recommends: thermald but it is not going to be installed
linux-modules-extra-4.4.0-184-generic : Depends: linux-image-4.4.0-184-generic but it is not going to be installed or
linux-image-unsigned-4.4.0-184-generic but it is not going to be installed
linux-modules-extra-4.4.0-185-generic : Depends: linux-image-4.4.0-185-generic but it is not going to be installed or
linux-image-unsigned-4.4.0-185-generic but it is not going to be installed
plesk-backup-utilities : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
Depends: sw-tar (>= 1.32) but 1.29-2.ubuntu16.04.17051015 is to be installed
Depends: plesk-libpoco-1.9.0 but it is not going to be installed
Conflicts: log4cpp-plesk (< 0.3.6) but 0.3.5rc2.1-ubuntu16.04.16111617 is to be installed
plesk-base : Depends: plesk-release-17.8.11
plesk-config-troubleshooter : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
plesk-control-panel : Conflicts: plesk-skins (< 17.9.5) but 17.8.11-ubuntu16.04.build1708200408.19 is to be installed
plesk-core : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
Conflicts: plesk-management-node (< 18.0.23) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
Conflicts: psa-pylibplesk (< 17.9.1) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
Conflicts: psa-phppgadmin (< 5.1.100) but 5.1.99-ubuntu16.04.17062313 is to be installed
Conflicts: plesk-ext-catalog (< 1:1.1.0-149) but 1.1.0-148.18030120 is to be installed
Conflicts: plesk-ext-rest-api (< 1:1.0.0-33) but 1.0.0-32.18030120 is to be installed
plesk-core-utilities : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
plesk-service-node-utilities : Depends: plesk-libboost-locale1.65 but it is not going to be installed
postfix-pcre : Depends: postfix (= 3.1.0-3ubuntu0.3) but 3.4.8-v.ubuntu.16.04+p18.0.29.3+t200825.2156 is to be installed
pp18.0.29-bootstrapper : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
Depends: virt-what but it is not going to be installed
psa : Conflicts: plesk-base (< 17.9.7) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
psa-horde : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
psa-imp : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
psa-kronolith : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
psa-mail-driver-common : Depends: plesk-libpoco-1.9.0 but it is not going to be installed
psa-mnemo : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
psa-php-configurator : Depends: php-ioncube-loader (>= 10.4.0) but 10.0.3-ubuntu16.04.18021914 is to be installed
psa-phpmyadmin : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
psa-turba : Depends: plesk-mysql-server (>= 18.0) but 17.8.11-ubuntu16.04.build1708180301.19 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Installation will not continue
Error: The apt-get failed with the following message:
Not all packages were installed.
 
Please try this:

Code:
sudo apt install --fix-broken or sudo apt reinstall
sudo apt-get update
sudo apt-get upgrade
 
(ok) sudo apt install --fix-broken or sudo apt reinstall
(ok) sudo apt-get update
(ko) sudo apt-get upgrade
 

Attachments

  • temp.jpg
    temp.jpg
    130.1 KB · Views: 14
No Problem, try to fix it, if there any other error while the plesk-installation, feel free to write hree.
 
Back
Top