1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgraded from 8.6 to 9.0.0 - Can't stay logged in & No webmail.

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by rewen125, Dec 11, 2008.

  1. rewen125

    rewen125 Guest

    0
     
    [SOLVED] Can't stay logged in & No webmail.

    Please refer to the last post for solution

    Hey guys I've got a few problems since upgrading. I'll sum up everything so far..

    - Updated, but never got a log emailed (I forgot to tell it to use my email address..)

    - Logged in quite some time later. Nice new login screen, but messed up XP Skin after logging in. Changed Vista Skin to default. Oddly, this made the XP skin work better, but still no Vista Skin for me. So I removed every other Skin. Now I see the new Vista Skin.

    - I get logged out minute or two, or even less sometimes. I can get around a few pages but sure enough I get logged out after some amount of time. I've even changed the session setting from 30mins to 60mins (figured any kind of chance might make it 'click'). That didn't help.

    - After an hour or so I found the restart server option. Restarted server. This seemed to fix the problem.. for a while. Then I eventually was logged out. And it all started over again.

    Can anyone help me out? I was pretty naive to think that I could just update without issues.
     
  2. 2dareis2do

    2dareis2do Guest

    0
     
    No Webmail

    I have updated to the latest version but my horde webmail has also disappeared.

    Tried atmail but have problems sending mails.
     
  3. rewen125

    rewen125 Guest

    0
     
    2dareis2do: If you go to the updater you can install a Horde update which should solve that problem.

    ----

    I was able to do all updates using SSH for my installation. I am still getting logged out after about 20 seconds though, and if I turn on SPF protection then all incoming emails have no from addresses and the bodies are garbled.

    I have tried changing the session length in the control panel, I've tried changing it in various files on the server, all to no avail.
     
  4. 2dareis2do

    2dareis2do Guest

    0
     
    Still no horde

    I think I have the latest verson of plesk/horde support installed and it still does not seem to work.

    I managed to change the sendmail from Qmail to postfix. This did not fix the problem, but did give me some more info:

    Could not send message to SMTP server. Check you have access to send messages via the server and that all To/CC/BCC addresses are valid\nError: SMTP Server rejected email. Returned:554 Service unavailable; Client host [127.0.0.1] blocked using list.dsb.org

    list.dsb.org is used as part of the option to Switch on spam protection based on DNS blackhole lists.

    list.dsb.org is one of the DNS zones used by the DNSBL service

    Therefore I have switched this off and voila, Atmail is now sending emails to external sites without any problems.

    I am not sure though if this is because of this particular DNS zone or the service in general?

    Horde is still not working either and I just get a blank screen.
     
  5. 2dareis2do

    2dareis2do Guest

    0
     
    Here's an update

    This problem seems to be isolated to one of the DNS zones for DNSBL service. I have this taking out list.dsb.org and it now seems to working fine.

    Hope this helps someone.
     
  6. rewen125

    rewen125 Guest

    0
     
    My problem is now fixed.

    If you have or had ASL installed, it's restarting the psa service like crazy. I didn't even have ASL installed anymore before upgrading to Plesk 9 yet it was still doing this.

    My host in cooperation with Parallels removed the service, but I don't know the details. Hope this at least gives you something to look for

    You may also want to do a test php script, for a separate problem that I also had, but unrelated to the plesk login

    make_session.php:
    session_start();
    $_SESSION['test'] = 'This is a test variable';
    $_SESSION['another'] = 'Why not have more than one var..';
    print_r ($_SESSION);

    test_session.php:
    session_start();
    print_r ($_SESSION);

    If test_session comes up with an empty array then you need to edit php.ini, look for the session.save directory value and change it to /tmp or something that works. Or try and fix the directory that it's already using.
     
Loading...