• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved Upgrading subdomains when installing Microupdates => Error

King555

Silver Pleskian
Whenever I install a new Microupdate, I get a lot of error messages like the one in the attached image.

One part of the error message is German, it says "A domain with the name www.subdomain.domain.tld already exists."

I have to say, that I created an additional subdomain with www-prefix (for example subdomain.domain.tld => www.subdomain.domain.tld) for every subdomain on the server and placed a htaccess-file in the httpdocs-folder, which redirects to the subdomain without www.

I created these with Plesk 9.x, now I use Plesk 10.4.4 MU12.

What can I do?
 

Attachments

  • plesk upgrade error.gif
    plesk upgrade error.gif
    9.8 KB · Views: 10
Has anyone a solution for this?

EDIT: I think the problem is another one.

I cannot see my subdomains without "www" anymore! I only see the www-subdomains now. But the original subdomains still work.

When I want to edit the www-subdomain (remove www), Plesk tells me the subdomain already exists (of course it does, but it is invisible).

What can I do? It seems that the upgrade to version 10 produced some chaos.
 
Last edited:
Me again, sorry for pushing the thread, but my question/problem has changed.

Now I removed the www.subdomain from one of my domains via Plesk and deleted the complete directories (the subdomain and the www.subdomain) via SSH.

Then I wanted to create the subdomain again. But Plesk tells me, that subdomain already exists. There is an entry in the psa database (table "subdomains"). But I don't think that deleting this entry will help, because there has to be another setting for the apache server.

If I open subdomain.mydomain.tld in my browser there comes a "forbidden" message (because there is no content now), but if I open anything.mydomain.tld I am redirected to my main domain. So the subdomain is still active deep in the apache configuration.

How can I safely fix this problem? I don't want to mix up my whole configuration.

Thanks for any answers!

EDIT: Now I found a solution!

I deleted the entry in the Plesk database ("psa", table "subdomains") and then I saved the domain settings again. Then the subdomain was deleted in the Apache configuration and now I can recreate the subdomain.
 
Last edited:
Back
Top