1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrading to php 5.3

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by wxman, Jan 9, 2011.

  1. wxman

    wxman Guest

    0
     
    I'm on a Centos dedicated server running Plesk 10.0.1. I currently have php 5.2.16 and mysql 5.1.54 installed. Is it possible to upgrade php to either 5.2.5 or 5.3 without killing the whole system? Do I need to upgrade mysql too?
     
  2. lhwparis

    lhwparis Guest

    0
     
    its possible. plesk10 is compatible with php 5.3 and you dont have to update mysql.
     
  3. wxman

    wxman Guest

    0
     
    Thanks for the reply.
    I already tried the upgrade through yum using SSH, and 5.2.17 was as far as I could get it. There must be a a repository I'm not getting. I used the steps at PHP - Atomicorp Wiki as a guideline.
     
    Last edited by a moderator: Jan 9, 2011
  4. FredC

    FredC Basic Pleskian

    17
     
    Joined:
    Dec 9, 2010
    Messages:
    25
    Likes Received:
    0
    Hello,

    I'm looking too for a way to surely install (upgrade) to php 5.3.
    Should it be done using the Plesk panel, or not ?
    How ?

    Thanks for help.
     
  5. lhwparis

    lhwparis Guest

    0
     
    No its not possilbe via ControlPanel because PHP is NOT a part of Plesk! PHP is provided by the Operating system you use and Plesk just use it. So if you wanna update PHP search for update steps for your operating system and php or post your question in the forum for your operating system.

    Plesk is compatible with all PHP5 Versions.
     
  6. FredC

    FredC Basic Pleskian

    17
     
    Joined:
    Dec 9, 2010
    Messages:
    25
    Likes Received:
    0
    Thanks for answering.

    I use CentOS, so i'll look how to upgrade.
     
  7. lhwparis

    lhwparis Guest

    0
     
  8. FredC

    FredC Basic Pleskian

    17
     
    Joined:
    Dec 9, 2010
    Messages:
    25
    Likes Received:
    0
    Thanks.
    I saw that, but...

    From :
    http://wiki.centos.org/FAQ/CentOS5#head-8b85501ca7f023bc0eeb0fef98143e10fb6adefc
     
  9. lhwparis

    lhwparis Guest

    0
     
    yes there is NO official version. but you can update it "unoffical" if you want to do that...
    that doese not mean you can not compile it yourself or use the atomic-version.
     
  10. FredC

    FredC Basic Pleskian

    17
     
    Joined:
    Dec 9, 2010
    Messages:
    25
    Likes Received:
    0
    Ok.
    Maybe i'll try this...
     
  11. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    php 5.3.5 is available from the atomic-testing repo. You can install it with:

    yum --enablerepo=atomic-testing upgrade php
     
  12. FredC

    FredC Basic Pleskian

    17
     
    Joined:
    Dec 9, 2010
    Messages:
    25
    Likes Received:
    0
    I'm using CentOS 5 and php 5.1.6
    You mean that using your function only, i'll upgrade to php 5.3.5 ?
    So simply ?
     
  13. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Yup, you got it
     
  14. Jekkil

    Jekkil Guest

    0
     
    i upgraded from php 5.1x to 5.2.17 following your (very precious!) informations, but I got this message in mysql admin:
    Your PHP MySQL library version 5.0.90 differs from your MySQL server version 5.1.54. This may cause unpredictable behavior.
    what should i do about it?
     
  15. N3cTr0

    N3cTr0 Guest

    0
     
    Your PHP MySQL library version 5.0.90 differs from your MySQL server version 5.1.54. This may cause unpredictable behavior.

    Same Error
     
  16. DCR

    DCR Guest

    0
     
    The good thing about Centos and the reason we use it is because it stays stable for a long time.
    Unfortunately that also means that the official Centos packages stay "old" for a long time.

    Fortunately we can either port new stuff (such as PHP 5.3) ourselves, or get packages from good natured and helpful companies like Atomic Corp.

    I have myself upgraded to PHP 5.3.5 from Atomic, and I see the same error message caused by the fact that the php mysql client libraries cannot easily be upgraded from the native CentOS version (5.0.90).

    As the Mysql FAQ on Atomic (http://www.atomicorp.com/wiki/index.php/Mysql) states it:
    ---------------
    MySQL Library Differs

    When using some tools (most notably PHPMyAdmin) you may get a notice like this

    Your PHP MySQL library version 5.0.90 differs from your MySQL server version 5.1.50. This may cause unpredictable behavior.

    This message can be safely ignored. The reason that the library cannot be upgraded with the server is that, in Enterprise Linux, everything is compiled around the old library. Upgrading the library would break a number of programs compiled against it so, for compatibility's sake, it must remain as the one provided by the vendor directly.

    If you REALLY need the latest libraries you can recompile php from the SRPMS.
    ---------------

    I see the message from phpmyadmin.. I see other threads here stating that despite the Atomic statement about ignoring it, phpMyAdmin to some people seem to actually misbehave. Personally I just ignore it. I do not use phpmyadmin very often, but instead manage all databases from mysqlbench. (I do not have the need to separate databases into individual domains as Plesk otherwise provides.) I want to see them all under one hat. So I am just lucky that way, I guess. :)
     
  17. DCR

    DCR Guest

    0
     
    I should add to my earlier reply, that I just tried to install the upgrade to Plesk 10.1.1, while running an otherwise perfect PHP 5.3.5 setup.

    The upgrade fails miserably (leaving Plesk at version 10.0.1) because it cannot figure out to handle the later PHP version. On the way it apparently tries to downgrade PHP to a < PHP 5.2 version and failing to do this, failing the upgrade entirely.

    So beware.
     
  18. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    I believe Plesk 10 requires SiteBuilder (why is beyond me), which brings in a php5-ioncube-loader package from Plesk which only works with 'php < 5.2.0'. So yeah, Plesk seems to block using PHP 5.2+ indirectly this way... :(
     
  19. Gene Steinberg

    Gene Steinberg Regular Pleskian

    25
    57%
    Joined:
    Dec 9, 2008
    Messages:
    119
    Likes Received:
    0
    This is what makes me disenchanted with Plesk. Sure, upgrade PHP, Apache, etc., so long as you do it via the command line. cPanel offers a simple, graphical upgrade tool, EasyApache, where you can add Apache and PHP, plus the usual run of modules (including EAccelerator). Not that I hate command lines, but I have better things to do with my time. Once the initial configuration is done, and the Web host usually takes care of that, your EasyApache upgrade process is just clicks away.

    Yes, Plesk has a prettier interface, but I'm surprised this capability isn't present.
     
  20. gtsupport

    gtsupport Guest

    0
     

    simple answer: nobody should administrate any servers without command line skills. cpanel is for children. and my answer is not sarcastic !
     
Loading...