1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Using Plesk only for web not e-mail

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by FlorisB, Nov 19, 2011.

  1. FlorisB

    FlorisB New Pleskian

    16
    35%
    Joined:
    Feb 5, 2011
    Messages:
    10
    Likes Received:
    0
    What is the proper way to use Plesk for webhosting only and not for e-mail?
    We already have a separate mailserver setup for that.

    I disabled the "Enable mail management functions in Panel" box, and set the number of e-mail boxes to 0 for all packages.
    Also the MX-records for the domain are set to the proper external mailserver.
    But when PHP web applications send e-mail qmail still thinks the domain is local:


    Regenerating the configuration files with "/usr/local/psa/admin/sbin/mchk --with-spam" does not help either.
    The domains are still listed in the /var/qmail/control/rcpthosts and virtualdomains configuration files.
     
  2. md3vxx

    md3vxx Guest

    0
     
    Are you using your Plesk box for DNS servers or are you hosting DNS elsewhere?

    There are a number of ways to handle this sort of configuration but it would be helpful to have a few more details about your setup.
     
  3. FlorisB

    FlorisB New Pleskian

    16
    35%
    Joined:
    Feb 5, 2011
    Messages:
    10
    Likes Received:
    0
    DNS is external, and works fine.
    E-mail from other providers arrives fine.

    It is just that e-mail generated by PHP websites hosted on the Plesk box does not arrive.
    Due to Plesk writing in the qmail configuration files that the domains are local, while they are not.
     
    Last edited: Nov 20, 2011
  4. Christian_S

    Christian_S Basic Pleskian

    17
    35%
    Joined:
    Nov 8, 2010
    Messages:
    35
    Likes Received:
    0
    1. Open the domain in the Controlpanel
    2. Click Mail
    3. Click "Change Settings" og uncheck "Activate mail service on domain"

    Mails will now be delivered to the proper external mailserver.
     
  5. FlorisB

    FlorisB New Pleskian

    16
    35%
    Joined:
    Feb 5, 2011
    Messages:
    10
    Likes Received:
    0
    Aargh...
    It seems that "Mail" settings window is not available unless you assign POP3 mailboxes to the package...

    So I need to allow customers to create mailboxes in Plesk, to be able to DISABLE Plesk local mail's handling?! :(
     
    Last edited: Nov 20, 2011
Loading...