• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Where to change plesk_saslauthd log level?

Baxil

New Pleskian
Plesk 12.0.18 Update #70, Ubuntu 14.04.3 LTS.

Our postfix mail log file is filled with millions of lines like the following:

Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: activity on 1 channel(s)
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: new client (fd=10) registered
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: main cycle iteration
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: activity on 1 channel(s)
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: some read activity on client 10
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 2)=2
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=0]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 7)=7
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=1]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 2)=2
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=2]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 8)=8
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=3]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 2)=2
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=4]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 4)=4
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=5]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 2)=2
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=6]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: read(10, &buf, 15)=15
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: processing client data chunk [state=7]
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: failed mail authenticatication attempt for user 'xxxxxxxxxxxxxxx' (password len=9)
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: main cycle iteration
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: activity on 1 channel(s)
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: some write activity on client 10
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: attempt to write(10, &buf, 4)
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: client 10 processed
Oct 28 17:00:42 cloud8 plesk_saslauthd[17698]: main cycle iteration
Oct 28 17:00:42 cloud8 postfix/smtpd[17706]: warning: unknown[x.x.x.x]: SASL LOGIN authentication failed: authentication failure​

This is causing the log file to grow to unmanageable sizes.

I have tried decreasing the log_level in /etc/postfix/sasl/smtpd.conf from 4 to 1 with no change.
http://kb.odin.com/en/113866 suggests changing it at
/usr/lib64/sasl2/smtpd.conf but that file does not exist (nor in /usr/lib/sasl2).
http://kb.odin.com/en/125625 suggests adding "sql_verbose: no", but that has no effect either.
In both cases I reloaded postfix after the changes.

Where is the log level for plesk_saslauthd set, and what log level removes all of the debugging information except for the "failed mail authentication" line?
 
Back
Top