1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Wordpress Multisite / Symlink Issue

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by 41dreams, May 2, 2012.

  1. 41dreams

    41dreams Guest

    0
     
    Wordpress Multisite hosted on Media Temple. I added a new DNS Zone file and added a new "Subscription" (Plesk allows you to create Subscriptions for your domains which I need in ordper to setup email for these domains on that server). I then created a symlink so that the new Subscrition folder would point to the same folder as mainsite.com. Everything Was working fine, the newdomain.com was pointing to the central folder and the domain was resolving to the correct theme. Then yesterday, seemingly randomly, it just stopped working.

    Symlinks are no longer pointing newsite.com to the theme on mainsite.com. Now it is pointing to the server IP which is defaulting to the main domain on the server. Anyone have any ideas on why this might be and how to fix it?

    I double checked and all of the symlinks still exist.
     
  2. iHuman

    iHuman Basic Pleskian

    26
    73%
    Joined:
    Jul 18, 2006
    Messages:
    82
    Likes Received:
    2
    When using Wordpress Multisite:
    - all sites run off you primary domain (the default one for the IP in Plesk)
    - make sure you are using the domain mapping plugin to map all other domains (in WordPress)
    - to add email, in Plesk, go to the primary domain, add New Domain and select No Hosting as the hosting type
    - doing it this way, you don't need symlinks
    - then add you email accounts for the new domain

    elaine
     
Loading...