1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

yet another open_basedir question...

Discussion in 'Plesk for Linux - 8.x and Older' started by mrdan, Feb 16, 2007.

  1. mrdan

    mrdan Guest

    0
     
    I have searched for help on this and tried everything I found, but it still won't work.

    I use the folder /httpdocs/common/ for all my php include files. I have one main include file, and within that file, I include about 4 others. Each time I setup a domain, open_basedir restrictions are in effect, and the way I do things doesn't work. I've tried everything I found regarding creating a vhost.conf file, and nothing works except directly editing the httpd.include file to comment out the open_basedir lines. I hate messing around inside that file, but it's all I can get to work. Plus, every time plesk rewrites the config file, I lose my edits.

    I've entered this in the vhost.conf file:
    <Directory /var/www/vhosts/mydomain.com/httpdocs>
    php_admin_value open_basedir "/var/www/vhosts/mydomain.com/httpdocs:/tmp:/var/www/vhosts/mydomain.com/httpdocs/common"
    </Directory>

    I've tried with and without quotes, with and without the path in the first Directory tag... nothing works. When I run the websrvmng utility, it drops this line into httpd.include: Include /var/www/vhosts/mydomain.com/conf/vhost.conf. Then I restart apache... no go. I checked that the user and group for vhost.conf are both root. I tried anything I could think of, as I know plesk is particular with permissions. Is there some way for me to tell plesk to just not put the open_basedir lines in the httpd.include config files?

    I'm feeling like it's just a syntax problem, but I have copied the advice online exactly, and I still can't get it to work.

    Any suggestions? I'm using a GoDaddy dedicated with Linux 2.6.17-1.2142_FC4 and psa v8.0.0.

    Thanks!
    Dan
     
Loading...