1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Zend on RHEL3 with PHP4.3.2

Discussion in 'Plesk for Linux - 8.x and Older' started by nickpick, Jan 11, 2007.

  1. nickpick

    nickpick Guest

    0
     
    I installed Zend Optimizer 3.2.0 on my RHEL3 box. Installation was OK, according to the Zend installer script.
    However, it is not OK. Because the Zend Optimizer is not running.

    Googling around brought me to the Zend forum: http://www.zend.com/forums/index.php?t=rview&th=393&goto=2091

    So there seems to be a problem with Zend Optimizer on PHP 4.3.2
    Here is the result when i run /usr/bin/php -v

    Failed loading /usr/local/Zend/lib/Optimizer-3.2.0/php-4.3.x/ZendOptimizer.so: /usr/local/Zend/lib/Optimizer-3.2.0/php-4.3.x/ZendOptimizer.so: undefined symbol: zend_open
    PHP 4.3.2 (cgi), Copyright (c) 1997-2003 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies
    with the ionCube PHP Loader v2.5, Copyright (c) 2002-2004, by ionCube Ltd., and
    with Zend Extension Manager v1.0.11, Copyright (c) 2003-2006, by Zend Technologies

    As you can see some symbol from shared library cannot be resolved, I think the reason why mod_php does not load Zend_optimiser is the same.

    Has anyone experiences with this?
    How can I safely upgrade mod_php to 4.3.10 version?
     
  2. sflc2000

    sflc2000 Guest

    0
     
    We're having the same problem with same versions, we tried Zend Optimizer 2.6.2 and also 3.3.0a, with same results.

    Did you find a resolution to the problem?
     
  3. nickpick

    nickpick Guest

    0
     
    Hello,

    No, it was never resolved.
    We just picked another server with RHEL4 install to install the Zend.
     
Loading...