• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

10.3.1, Changing Default Apache Ports*

nevakee

Basic Pleskian
10.3.1, Changing Default Apache Ports

Hello,

I changed the Apache port successfully, as described below http://download1.parallels.com/Ples...nistration-guide/index.htm?fileName=68800.htm.
It works perfectly, but apache2 does about 30 seconds to restart. Plesk does not report an error in the admin interface.

psa v10.3.1_build1013110726.09 os_Debian 5.0

xxx:~# apache2ctl configtest
Syntax OK
xxx:~#
xxx:~# /etc/init.d/apache2 restart
Restarting web server: apache2 ... waiting .
xxx:~#

#######

errorlog (restart over plesk panel, eg domain changes):
[Mon Sep 26 16:50:57 2011] [notice] caught SIGTERM, shutting down
[Mon Sep 26 16:51:34 2011] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Mon Sep 26 16:51:34 2011] [notice] Apache/2.2.9 (Debian) mod_fcgid/2.3.6 proxy_html/3.0.0 mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
syslog:
Sep 26 16:51:03 xxx websrvmng[882]: httpd stop failed
Sep 26 16:51:03 xxx websrvmng[882]: 0 /usr/sbin/apache2 processes are killed

#######

errorlog (/etc/init.d/apache2 restart):
[Mon Sep 26 16:55:07 2011] [notice] caught SIGTERM, shutting down
[Mon Sep 26 16:55:08 2011] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Mon Sep 26 16:55:09 2011] [notice] Apache/2.2.9 (Debian) mod_fcgid/2.3.6 proxy_html/3.0.0 mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations

#######

errorlog (/usr/local/psa/admin/bin/websrvmng --restart):
[Wed Sep 28 18:04:30 2011] [notice] caught SIGTERM, shutting down
[Wed Sep 28 18:04:33 2011] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Wed Sep 28 18:04:33 2011] [notice] Apache/2.2.9 (Debian) mod_fcgid/2.3.6 proxy_html/3.0.0 mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operationsnormal operations

#######

What could be the problem?

Best regards
 
Last edited:
restart over plesk panel, eg domain changes:
/opt/psa/admin/bin/websrvmng --restart --restart-interval 0 --http-port 80 --https-port 443

Apache2 port is 8080 and not 80!
proxy/cache server run on port 80.

How can I change the --http-port parameters?


That works perfectly:
/opt/psa/admin/bin/websrvmng --restart --restart-interval 0 --http-port 8080 --https-port 443
 
Back
Top