1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

10.4.4 not restarting apache immediately

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Hostasaurus.Com, Feb 1, 2013.

  1. Hostasaurus.Com

    Hostasaurus.Com Regular Pleskian

    30
    68%
    Joined:
    Oct 8, 2009
    Messages:
    465
    Likes Received:
    8
    One of our 10.4.4 servers has recently begun not immediately applying changes that would have required an apache restart, specifically SSL certificate replacement. I noticed the following process gets spawned once such a change is made:

    /usr/local/psa/admin/bin/apache_control_adapter --restart --restart-interval 999999 --http-port 80 --https-port 443 --graceful

    I'm hoping the 999999 doesn't mean it intends to wait more than ten days (if it's seconds) to restart apache. We've left it for up to an hour with no restart before doing it ourselves to get the new cert in place. Any ideas?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  3. Hostasaurus.Com

    Hostasaurus.Com Regular Pleskian

    30
    68%
    Joined:
    Oct 8, 2009
    Messages:
    465
    Likes Received:
    8
    It ended up being the apache restart interval setting found in the panel and in the misc table of the psa database so that we can set it via a script. For some reason this value on all previous installs of 10.4.4 defaulted to zero and on this one server it took the value 999999. We'll start setting the value explicitly going forward.
     
Loading...