• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

12.5 upgrade failure - database error

VinnyT

Regular Pleskian
Hi. I am trying to upgrade from plesk 12.1.xx to 12.5.28. My installation fails with the error below. Is there an easy way to modify the database version number so that the installation will continue?


===> Upgrading database

Trying to start service mysqld... mysqld (pid 10715) is running...
done
Trying to establish test connection... connected
done
Trying to find psa database... version is 012005028
DATABASE ERROR!!!
Previous product version is 12.1.25, but previous database
version is 012005028. In most of cases it is result of
previous upgrade try failure. Please, restore previous version
from backup, and try again or contact technical support.

ERROR while trying to check database version
Check the error reason(see log file: /var/log/plesk/install/plesk_12.5.29_installation.log), fix and try again


Trying to start psa...
Stopping sw_engine service... already stopped

**** Product prep-install for BASE failed.

***** problem report *****
ERROR while trying to check database version

Check the error reason(see log file: /var/log/plesk/install/plesk_12.5.29_installation.log), fix and try again
STOP Bootstrapper 12.5.29 prep-install for BASE AT Fri Aug 28 13:39:51 CDT 2015
 
BTW, we do not support upgrade to Plesk 12.5 Preview version.
 
Ok, that will work. Thanks!! So what should I put for the database version? In the error log, my Previous product version is 12.1.25. What should i put for the version number?

Thanks!
 
Here are my command outputs:

cat /usr/local/psa/version12.1.25 CentOS 6 1201150619.19
[ [email protected] ~ ] > mysql -uadmin -p`cat /etc/psa/.psa.shadow` -e"select * From psa.misc where param='version'"
+---------+-----------+
| param | val |
+---------+-----------+
| version | 012005028 |
+---------+-----------+
 
Ok, but the official release isn't going to solve this problem if the version numbers are out of sync... this is a result of me using please 12.1.x and now i'm stuck with it.
 
The simplest solution would be to replace the data in /usr/loca/psa/version, right? Right now I have: 1201150619.19
My DB is showing: 012005028.

Should i change the /psa/version number to just 012005028 ?
 
Back
Top