1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

7.5.3 > 7.5.4 Upgrade Errors (Dependencies)

Discussion in 'Plesk for Linux - 8.x and Older' started by md3vxx, Sep 6, 2005.

  1. md3vxx

    md3vxx Guest

    0
     
    Hello,

    We are unable to upgrade to the latest build due to dependency problems:

    ==
    [root@s1 base]# rpm -Uvh *
    error: Failed dependencies:
    libgcc_s_plesk.so.1 is needed by psa-7.5.4-rhel3.build75050824.12
    libgcc_s_plesk.so.1(GCC_3.0) is needed by psa-7.5.4-rhel3.build75050824.12
    libgcc_s_plesk.so.1(GLIBC_2.0) is needed by psa-7.5.4-rhel3.build75050824.12
    libstdc++_plesk.so.6 is needed by psa-7.5.4-rhel3.build75050824.12
    libstdc++_plesk.so.6(CXXABI_1.3) is needed by psa-7.5.4-rhel3.build75050824.12
    libstdc++_plesk.so.6(GLIBCXX_3.4) is needed by psa-7.5.4-rhel3.build75050824.12
    plesk-libgcc-3_4 is needed by psa-7.5.4-rhel3.build75050824.12
    plesk-libstdc++-3_4 is needed by psa-7.5.4-rhel3.build75050824.12
    libgcc_s_plesk.so.1 is needed by psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    libgcc_s_plesk.so.1(GCC_3.0) is needed by psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    libgcc_s_plesk.so.1(GLIBC_2.0) is needed by psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    libstdc++_plesk.so.6 is needed by psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    libstdc++_plesk.so.6(CXXABI_1.3) is needed by psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    libstdc++_plesk.so.6(GLIBCXX_3.4) is needed by psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    libgcc_s_plesk.so.1 is needed by psa-qmail-1.03-rhel3.build75050824.12
    libgcc_s_plesk.so.1(GCC_3.0) is needed by psa-qmail-1.03-rhel3.build75050824.12
    libgcc_s_plesk.so.1(GLIBC_2.0) is needed by psa-qmail-1.03-rhel3.build75050824.12
    libstdc++_plesk.so.6 is needed by psa-qmail-1.03-rhel3.build75050824.12
    libstdc++_plesk.so.6(CXXABI_1.3) is needed by psa-qmail-1.03-rhel3.build75050824.12
    libstdc++_plesk.so.6(GLIBCXX_3.4) is needed by psa-qmail-1.03-rhel3.build75050824.12
    ==

    Does anyone know the solution for this?
     
  2. md3vxx

    md3vxx Guest

    0
     
    Fix

    We resolved this problem by installing the files

    - binutils-2.15-1.i586.rpm
    - plesk-cpp-3_4-3.4.3-2.i586.rpm
    - plesk-gcc-3_4-3.4.3-2.i586.rpm
    - plesk-gcc-c++-3_4-3.4.3-2.i586.rpm
    - plesk-libgcc-3_4-3.4.3-2.i586.rpm
    - plesk-libstdc++-3_4-3.4.3-2.i586.rpm
    - plesk-libstdc++-devel-3_4-3.4.3-2.i586.rpm

    From the tarball Plesk download in folder: Third_Party.RHel3

    Thanks.
     
  3. dm__@

    dm__@ Guest

    0
     
    Re: Fix

    You're only required to install plesk-libgcc and plesk-libstdc++. Other ones are development packages. Dunno why Plesk released 'em.
     
Loading...