1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

7.5.3 upgrade failed, server doesn't boot. URGENT HELP, PLEASE

Discussion in 'Plesk for Linux - 8.x and Older' started by hovik, Jul 9, 2005.

  1. hovik

    hovik New Pleskian

    22
    57%
    Joined:
    Jul 9, 2005
    Messages:
    13
    Likes Received:
    0
    I'm running Plesk 7.5.2 on RH9. Recently the auto-upgrader suggested to download and install 7.5.3. After some time I received an email saying that the upgrade procedure has failed.

    I tried to log in to the control panel as admin, but after validating the password, the panel brought an empty page. I tried it several times - same result.

    I then rebooted the server and it didn't come up.

    I switched to 1and1's rescue shell and found out that the filesystem looks ok, and no signs of failure in the system logs. The server actually starts up, works up to a minute or two and then suddenly goes down.

    I need urgent help on this, since I host many web sites. Thanks!

    I already contacted the support, no answer so far.
     
  2. sieb@

    sieb@ Guest

    0
     
    Did you contact 1and1's support? Can you ssh into it at all? A PSA update itself won't crash a server, just PSA itself.
     
  3. hovik

    hovik New Pleskian

    22
    57%
    Joined:
    Jul 9, 2005
    Messages:
    13
    Likes Received:
    0
    I'm able to start a rescue shell from RAM, from where I see everything on my disks.

    The error message in the upgrade log was:

    Database integrity check failed: duplicate values of (upgrade_date) exist in table upgrade_history

    I managed to start mysqld and httpd in the rescue shell, then removed all records from this table 'upgrade_history', and am now trying to run the upgrade from the command line.

    Will keep you posted.

    Any suggestions on what might cause the server shut down immediately after boot?
     
  4. hovik

    hovik New Pleskian

    22
    57%
    Joined:
    Jul 9, 2005
    Messages:
    13
    Likes Received:
    0
    The upgrade went through smoothly this time, but the server still doesn't start!

    I need this to be fixed urgently. Please, please.
     
Loading...