• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

7.5.4 upgrade broke Apache

spaceout

Basic Pleskian
Just upgraded from 7.5.3 to 7.5.4 and now Apache won't start. Here is the error when trying to start it:

httpd: could not open document config file /etc/httpd/conf/vhosts/ssl

That file doesn't even exist. Anyone know what's up?
 
Maybe fixed?

Well...I ended up just creating a blank file called ssl in that location.

Then I got an almost identical error about a file called normal that should be in the same location so I created a blank file called normal as well.

Now Apache started and seems to be working. However, is this going to cause any problems in the future?

Thanks
 
My setup has four directories that start with ssl:
ssl.crl
ssl.crt
ssl.csr
ssl.key
ssl.prm

What is it trying to load?
 
I have those in the conf directory as well. Mine was breaking trying to load files that should have been in the vhosts directory inside of conf. Not sure why they weren't there.
 
looked for the saved config files that plesk saves when it upgrades and compare the current conf file with the old one.

previously I've had to restore older versions of my config files to get things working again. I would say that installs are MUCH better now than they were with plesk 6.. (totally manual back then).
 
Back
Top