1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

7.5.4 Upgrade failed, force?

Discussion in 'Plesk for Linux - 8.x and Older' started by ridgey, Aug 29, 2005.

  1. ridgey

    ridgey Guest

    0
     
    Hi there,

    Apon failure of the auto updating from the Plesk Admin Console and also failure on the auto updater rpm, I have downloaded the complete package and attempted to install the base packages manually to get the upgrade moving along. I get the following :

    [root@psa2 base]# rpm -Uvh psa-locale-base-en-US-7.5.4-rh9.build75050824.12.noarch.rpm
    error: Failed dependencies:
    psa-locale-base = 7.5.3 is needed by (installed) psa-7.5.3-rh9.build75050506.13
    [root@psa2 base]#
    [root@psa2 base]#
    [root@psa2 base]#
    [root@psa2 base]# rpm -Uvh psa-7.5.4-rh9.build75050824.12.i586.rpm
    error: Failed dependencies:
    psa-api-cli >= 7.5.4 is needed by psa-7.5.4-rh9.build75050824.12
    psa-api-common >= 7.5.4 is needed by psa-7.5.4-rh9.build75050824.12
    psa-locale-base = 7.5.4 is needed by psa-7.5.4-rh9.build75050824.12
    psa = 7.5.3 is needed by (installed) psa-bu-7.5.3-rh9.build75050506.13

    Is this normal?? should i just force these through? or should it be approached another way. Any help appreciated.

    Regards
     
  2. dm__@

    dm__@ Guest

    0
     
    hmm... I'd suggest upgrading all the 'base' packages at one RPM invokation.
     
  3. ridgey

    ridgey Guest

    0
     
    I have

    I have tried that also :

    [root@psa2 base]# rpm -Uvh *
    error: Failed dependencies:
    psa = 7.5.3 is needed by (installed) psa-bu-7.5.3-rh9.build75050506.13
    psa-api-common = 7.5.3 is needed by (installed) psa-api-rpc-7.5.3-rh9.build75050602.16
     
  4. dm__@

    dm__@ Guest

    0
     
    Re: I have

    You also need to install opt/bu and opt/api RPM simultaneously
     
  5. YorkshireSteve

    YorkshireSteve Guest

    0
     
    Hello!

    I'm getting the same problem as described above, on a 1&1 server.

    Here's what I get in the failure report:
    Code:
    Preparing for packages installation...
    ----- begin of output -----
    Installing /PSA_7.5.4/rpm_RedHat_9/base/psa-locale-base-en-US-7.5.4-rh9.build75051115.01.noarch.rpm
    error: Failed dependencies:
    	psa-locale-base = 7.5.3 is needed by (installed) psa-7.5.3-rh9.build75050506.13
    
    ----- end of output -----
    ...and the following when I run 'rpm -Uvh *.rpm --force' from the command line:
    Code:
    error: Failed dependencies:
            psa-locale-base = 7.5.3 is needed by (installed) psa-7.5.3-rh9.build75050506.13
    
    I haven't had too much trouble trouble using the updater before, so I'm pretty new to having things break and need upgrading manually.

    Regards,

    Steve
     
Loading...