1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.0.1 data restore failing with ERROR: PleskDOMException

Discussion in 'Plesk for Linux - 8.x and Older' started by dtb71, Oct 1, 2006.

  1. dtb71

    dtb71 Guest

    0
     
    Before posting I searched but couldn't find an answer - sorry if I'm posting an already discussed/solved issue...

    I am moving from one server to another - with different IP addresses... here's what I did:
    Old server = 206.xxx.xxx.xxx - Plesk 8.0.0 - Fedora Core 4
    New server = 66.xxx.xxx.xxx - Plesk 8.0.1 - Fedora Core 4


    I created the backup on the old server using:
    /usr/local/psa/bin/pleskbackup --all /home/plesk_backups/plesk_daily_Backup


    it created 3 files:
    plesk_daily_Backup
    plesk_daily_Backup.001
    plesk_daily_Backup.002


    I ftp'd (binary mode) the 3 files over to the new server with no issues


    On new server I created the map file:
    /usr/local/psa/bin/pleskrestore --create-map plesk_daily_Backup -map pleskDataMap


    I made (1) change in the map file to update the IP address:
    206.xxx.xxx.xxx -> 66.xxx.xxx.xxx


    I validated the map:
    /usr/local/psa/bin/pleskrestore --validate-map pleskDataMap
    Map file validates


    I attempted to restore all data and got multiple errors with huge xml dump:


    /usr/local/psa/bin/pleskrestore --restore plesk_daily_Backup -level all -map pleskDataMap
    ERROR: PleskDOMException
    Malformed XML:

    0: /usr/local/psa/admin/plib/PMM/MigrationDemon.php:76
    DaemonRunner::validateXml(string '<?xml version='1.0' encoding='UTF-8'?>
    <action>
    <set-migration-objects>
    <selected-objects><migrate-server><client><name>newleaftoday</name><ip><old><ip-type>shared</ip-type><ip-address>206.xxx.xxx.xxx</ip-address></old><new><ip-type>shared</ip-type><ip-address>66.xxx.xxx.xxx</ip-address></new></ip><domain><name>

    ....and this xml dump goes on and one with a few more errors

    I tried several times and no go.

    Anyone seen this problem or have a solution for me?

    I've done a restore before on Plesk 8.0.0 on the same box (after loosing a hard drive) and it worked flawlessly... but this is failing immediately!?!

    THANKS FOR YOUR HELP!!
     
  2. dtb71

    dtb71 Guest

    0
     
    Well - I got no help or support from swsoft... until after I resolved the problem! They could have saved me 2+ hours of wasted time!

    So - here's what I did:

    Well, actually, first the swsoft response... "check and upgrade if needed your Plesk to the latest 8.0.1 build with all hotfixes and backup utilities "
    Gee... thanks! I wish they would have responded this way when I called on the phone. Could have pointed me to the new backup tool and eliminated over 2 hours of wasted time and frustration!

    Anyway - after doing my own searching I found a posting in the forums for a NEW and UPDATED backup utility "Plesk Backup Agent v8.0.1" - you can read about it here: ftp://download1.swsoft.com/Plesk/Plesk8.0/Extensions/bu/backup-agent-8.0.1.html

    So I downloaded the new backup utility and re-ran the whole scenario (created the backups, ftp'd them over, created map and attempted restore) and it seems to have worked just fine!

    Must have been a bug in the backup utility in v8.0.0 ??
     
Loading...