1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.2 Slow mail delivery and other mail rejects

Discussion in 'Plesk for Linux - 8.x and Older' started by kturby, Jul 17, 2007.

  1. kturby

    kturby Guest

    0
     
    We noticed after upgrading to 8.2 a sudden spike in complaints about undelivered mail and very slow delivery.

    However, it was not consistent.

    I put in a support ticket with Plesk a day or so ago, but have not heard back from them yet. I'm sure they're busy with lots of upgrade issues.

    Experimenting, we found SMTP port 25 was responding extremely slowly. We looked for solutions and found the -Rt0 mentioned -- but that was already in our smtp_psa file.

    Looking at the rest of the smtp_psa file, we noticed the RBL block list in there. So, we went in to the server console and UNCHECKED both the SPF option and the Block list option at the server mail settings. The problem went away immediately.

    I'm STILL not sure as to the real solution -- the SPF and RBL settings are the exact same as in 8.1. I'm assuming there is a better solution than simply disabling both?

    Anyway, I'm posting here in hopes someone might have a solution, and of course to pass on in case the same is seen experienced by anyone else and this may help as a temporary fix.
     
  2. CruzMark

    CruzMark Basic Pleskian

    24
    23%
    Joined:
    Mar 6, 2006
    Messages:
    84
    Likes Received:
    0
    Check with the RBL and see if they've blocked access from your server. Spamhaus recently did that to us and we saw the exact same behavior.

    Paying Spamhaus for their service and setting up a local feed solved the issue.

    And Spamhaus is worthy of your dollars.
     
  3. kturby

    kturby Guest

    0
     
    Thanks. It seems unlikely that is the core problem in this case. Primarly, because ANY blacklist entry seems to cause the slowdown, and also, it occurs if EITHER the SPF or the RBL option is turned on.

    In addition, it started immediately with the 8.2 upgrade. It would seem more logical this has something to do with changes in programs or configuration related to that upgrade process.

    The settings are the exact same as what had been working for months prior with 8.1.
     
  4. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    Hi Keith,

    I had the same problem after upgrading some 8.1 Plesk servers to 8.3. After long hours of going through everything I eventually found that Plesk didn't have either of the files:

    /var/qmail/control/concurrencyremote
    /var/qmail/control/concurrencylocal

    I created them with value 500 for local and 250 for remote, restarted qmail .. and that got it going like ... something that goes very fast..

    FWIW

    PS. In my case RBL and SPF settings made no difference to the delivery speed.
     
  5. blank_page

    blank_page Regular Pleskian

    24
    53%
    Joined:
    Dec 17, 2006
    Messages:
    229
    Likes Received:
    0
    Hi,


    disable reverse lookups in /etc/xinetd.d/smtp_psa by adding the -Rt0 argument to the server_args

    front of the arg line like:

    server_args = -Rt0 xxxxx xxx


    then restart xinetd and qmail.....
     
  6. nathacof@

    nathacof@ Guest

    0
     
    You may want to check your DNS servers to ensure that they are operating correctly. From the sound of your problem it appears that any DNS lookup is causing delays (IE: RDNS, RBL lookup, SPF lookup).

    Check with your hosting provider to ensure that you are using their newest caching name servers.

    Your name server configuration is located in /etc/resolv.conf. Bare in mind if you are running a Virtuozzo VPS you'll need to configure these on the hardware node.
     
  7. Manetheren

    Manetheren Guest

    0
     
    /var/qmail/control/concurrency*

    madsere et al

    are the /var/qmail/control/concurrency* vital? I don't have them on my 8.2.1 install either.

    tried googling and couldn't find an example of them.

    I've been having all sorts of mail issues since upgrading :(
     
  8. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    I'm not sure, it worked for me though so worth a try. Create the two files, one with the value "500" the other with "250", then restart qmail and see if it makes a difference for you.
     
  9. sprovis

    sprovis Guest

    0
     
    I have the same problem but do not have a /etc/xinetd.d/smtp_psa file - any ideas???? (seems this issue has been ongoing since 2005 - I'm amaized it's not fixed yet)
     
Loading...