1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Activate customer with API It does not work

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by inxenio, Feb 4, 2011.

  1. inxenio

    inxenio Guest

    0
     
    We have a problem with Plesk API 1.6.3.0 when We want to re-activate a suspended customer.

    Tested on development servers Linux CentOS 5.5 x64 With Plesk 10.1.1 and Windows Server 2008 R2 x64 with Plesk 10.0.1.

    Same problem on two servers.

    The Problem:
    - I CAN suspend a customer on Plesk panel and reactivate it with API (using <status>0</status>)
    - I CAN suspend a customer with the API BUT I CANNOT reactivate with the API and YES on the Plesk control panel.

    If I suspend a customer with API I have to access to Plesk control panel and activate it manually.

    Please check this problem and solve it ASAP because can lead system to inconsistency.

    Regards :)
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  3. inxenio

    inxenio Guest

    0
     
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    - Plesk API 1.6.3.0
    - Tested on development servers Linux CentOS 5.5 x64 With Plesk 10.1.1 and Windows Server 2008 R2 x64 with Plesk 10.0.1.

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    a.- Suspend a customer from API and then try to reactivate it.
    b.- Suspend a suscription from API.

    ACTUAL RESULT
    a.- After I suspend the customer with API I cannot reactivate it (with API).
    b.- After I suspend a suscription from API I cannot access to http://www.domain.com but I can access to http://domain.com

    EXPECTED RESULT
    a.- A customer must be reactivable from API.
    b.- A suscription is not well suspended. Nor www.domain.com nor domain.com must be accesible after you suspend it.

    Regards.
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Thank you for report. I have forwarded it to developers for the further investigation. I will update thread with results as soon as I receive it.
     
  5. inxenio

    inxenio Guest

    0
     
    Thank you Igor ;)
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Developers have informed that neither suspend bug nor subscriptions suspend bug were not reproduced with attached api-rpc script.
     

    Attached Files:

    • rpc.zip
      File size:
      659 bytes
      Views:
      15
  7. inxenio

    inxenio Guest

    0
     
    Hello Igor. Definitely this is not working well.

    In a month of use, not all substriptions are well suspended and well activated. The API call is always the same but sometimes works well and sometimes not.

    When I suspend a domain (<status>16</status>) I can see 3 different results:

    - The domain is Well-Suspended, I cannot access to http://www.domain.com nor http://domain.com
    - The domain is Suspended (status 16) but I can access to http://www.domain.com (but not to http://domain.com).
    - The domain is suspended (status 16) but I can access to http://www.domain.com and to http://domain.com.

    In the 2nd and 3rd cases I must access to Plesk CP and activate the subscription and then suspend the suscription again.

    We test it on Linux and Windows servers.
     
Loading...