1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

adding "www" after doman creation

Discussion in 'Plesk for Linux - 8.x and Older' started by cherylchase, Aug 29, 2005.

  1. cherylchase

    cherylchase Guest

    0
     
    I set up a new domain, and apparently forgot to click the "www" on the setup.

    Now the domain displays for domain.com, but I get "There's no such domain registered on this server." for www.domain.org.

    After the fact, how to make it accept www?

    Cheryl
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    In the control panel, select Domains, select the affected domain.

    Click on DNS

    Checkmark the 'www prefix' box. Save changes.
     
  3. cherylchase

    cherylchase Guest

    0
     
    That seems confusing to me. First, I don't run my own dns (The Planet runs it for me). So this domain, like my other domains (all of which accept inquiries both with and without www) has dns disabled.

    However, if I enable dns, then there is a box to check for "www". However, there doesn't seem to be a way to save the new state. The only button nearby is "default", which offers to restore a default set of dns records.

    I'm running Plesk 7.5.3 on RHEL 3.
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Ah, so as long as you know The Planet's DNS records include either a CNAME or A record pointing www.domain.com to your server, then use SSH to login to the server as root, use a linux editor (such as nano, pico, or vi) check the following file:

    /home/httpd/vhosts/domain.com/conf/httpd.include

    Find the section which begins like:

    <VirtualHost xx.yy.zz.nn:80>
    ServerName domain.com:80
    ServerAlias www.domain.com
    UseCanonicalName Off

    Where 'xx.yy.zz.nn' is the IP address for the domain. Make sure the 'ServerAlias www.domain.com' line is there. If it is not, then add that line. Save the changes. Exit the editor. Restart Apache (either via the control panel, or from the command line: service httpd restart)

    Note: if you are not using a RedHat type Linux, the command 'service httpd restart' may have to be different for your OS.

    Note: Since your DNS is handled 'outside' of the Plesk server, then the Plesk DNS settings shouldn't matter, and this Apache config file should be the place to resolve your problem.

    Alternative: If you do not have SSH capabilities, then the other way to try setting it up would be to delete the Physical Hosting Setup for this domain (backup your domain directories and files first), then re-Setup hosting and make sure to select the 'www' option at the beginning.
     
Loading...