• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Apache conf files can not be built after upgrade to 10.3

R

RODRIGOT

Guest
After the upgrade from 10.1 to 10.3 at Panel home page, it shows the following message:

"Error: New files of configuration for Apache web server were not built due to errors in configuration templates. The detailed error message was e-mailed to you, so please check the e-mail, fix the errors, and click here to retry generating configuration."

e-mail shows the following:

"Generating new Apache configuration on host <64-150-190-113.dedicated.abac.net> failed because the following error(s) occurred:

Syntax error on line 54 of /var/www/vhosts/XXXXXXXXX*.com.br/conf/13115257400.27572800_httpd.include:
Invalid command 'SetEnv', perhaps misspelled or defined by a module not included in the server configuration


Please fix error(s) in templates of Apache configuration and retry generating the configuration file."

* the real name was changed to XXXXXXXXX for safety purposes.

System confs:

OS Linux 2.6.18-128.1.6.el5PAE
Panel version 10.3.0

NOTE: Nothing else was installed, any 3rd part app, nothing. Nor any custom conf was made.
 
I'm sorry, but how do I do That bootstrapper or install it manually?
 
Bootstraper done as:
/usr/local/psa/bootstrapper/pp10.12.0-bootstrapper/bootstrapper.sh repair

Still the same problem.

Don´t know how to perform it manually. Could you help?
 
After perform bootstrapper, in PLESK main page, it shows:
Error: New files of configuration for Apache web server were not built due to errors in configuration templates.
I did not edit any templates ever. I believe it is a bug on automated upgrade process.
How do I proceed?
 
We are having a very similar problem!

Can someone please enlighten us as to how to solve this issue?


/usr/local/psa/admin/sbin/httpdmng --reconfigure-all
PleskUtilException: '/usr/local/psa/admin/bin/apache_control_adapter' '--restart' '--restart-interval' '0' '--http-port' '80' '--https-port' '443' failed with code 255.

stdout:
Service /etc/init.d/apache2 failed to start
Service /etc/init.d/apache2 failed to start


stderr:
Service /etc/init.d/apache2 failed to start
Service /etc/init.d/apache2 failed to start

file: /usr/local/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 98
code: 0
trace: #0 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
#1 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
#2 /usr/local/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('7384a88e7d87a7b...', Array, Object(Service_Agent_Log))
#3 /usr/local/psa/admin/plib/Template/Writer/Apache.php(82): Service_Agent->commit()
#4 /usr/local/psa/admin/plib/Template/Configuration/Applier.php(202): Template_Writer_Apache->restart()
#5 /usr/local/psa/admin/plib/Template/Configuration/Applier.php(117): Template_Configuration_Applier->_applyConfigurationsToServiceNode(1, Array)
#6 /usr/local/psa/admin/plib/WebServerManager/Adapter/Apache.php(125): Template_Configuration_Applier->applyConfiguration(true)
#7 /usr/local/psa/admin/plib/WebServerManager.php(311): WebServerManager_Adapter_Apache->sync()
#8 /usr/local/psa/admin/plib/api-common/Httpdmng.php(117): WebServerManager->sync()
#9 /usr/local/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#10 {main}

2011-12-21T00:48:31+01:00 ERR (3): Apache config (13244249010.44677900) generation failed: Can not restart web server: Service /etc/init.d/apache2 failed to start
Service /etc/init.d/apache2 failed to start

Can not restart web server: Service /etc/init.d/apache2 failed to start
Service /etc/init.d/apache2 failed to start

PleskUtilException: /usr/local/psa/admin/bin/httpdmng '--reconfigure-domains' 'abc.com' failed with message: Empty error message from utility.
file: /usr/local/psa/admin/plib/common_func.php3
line: 1047
code: 0
trace: #0 /usr/local/psa/admin/plib/common_func.php3(965): util_exec('httpdmng', Array, Array, 'msg', NULL)
#1 /usr/local/psa/admin/plib/Os.php(17): smart_exec('httpdmng', Array, Array, 'msg')
#2 /usr/local/psa/admin/plib/Os.php(28): Os::exec('httpdmng', Array, 'msg')
#3 /usr/local/psa/admin/plib/api-common/Httpdmng.php(101): Os::execEx('httpdmng', Array)
#4 /usr/local/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#5 {main}

Execution failed.
Command: httpdmng
Arguments: Array
(
[0] => --reconfigure-domains
[1] => abc.com
)

Details: Empty error message from utility.
 
Back
Top