• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue Apache Error

Mikelito

New Pleskian
When I log in Plesk I see this error:

Code:
New configuration files for the Apache web server were not created due to the errors in configuration templates: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 66 of /etc/httpd/conf.modules.d/00-base.conf: Cannot load modules/mod_heartbeat.so into server: /etc/httpd/modules/mod_heartbeat.so: undefined symbol: ap_hook_watchdog_exit . Detailed error descriptions were sent to you by email. Please resolve the issues and click here to generate broken configuration files once again or here to generate all configuration files. See the details in Configuration Troubleshooter

And I can't start Apache.

Help me please.
 
Hi Mikelito,

Cannot load modules/mod_heartbeat.so into server: /etc/httpd/modules/mod_heartbeat.so: undefined symbol: ap_hook_watchdog_exit
Either consider to DISABLE the "heartbeat" module, or even try to uninstall it - btw. it's deprecated for RHEL7/CentOS7 - versions.
The error message points to "undefined symbol", which indicates, that the module is either not compiled for the current used apache - version, or you updated/upgraded your apache - webserver with issues/failures/problems and ignored to solve them.

Unfortunately you forgot to provide informations about your operating system, the used Plesk version ( incl. MU ) and the used apache - version, so that it is impossible for people willing to help you, to answer to your issue with complete commands. :(
 
Back
Top