1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Apache stops/starts after a period of time

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by SavinV, May 20, 2009.

  1. SavinV

    SavinV Guest

    0
     
    I have a problem with my apache on a Debian 4.0 distribution.
    The apache service stops and starts alone after some time.. but i don't know why.. i have read it's because it dosen't have free RAM Memory left to perate.. and in proccess I see sometimes apache2 <defunct> ..

    I have about 30+ websites hosted on the server + cs game servers, radio servers(with backup) and hub services(verlihub)..

    And i have a problem with MySQL too. Sometimes on the hosted sites that are using a db connection it says maximum connections reached..

    I modified the /etc/my.cnf the maximum connections allowed to 500.. and still gives that error..

    The main problem is the apache thing.. because all the sites goes down when the apache is stopped.

    I have watchdog on that tells me when the apache is down and when is up.. (here is a small preview):
    Events:
    [May 14, 2009 03:33 PM] 'Web Server (Apache)' service started.
    [May 14, 2009 03:28 PM] 'Web Server (Apache)' service stopped.
    [May 14, 2009 03:18 PM] 'Web Server (Apache)' service started.
    [May 14, 2009 03:12 PM] 'Web Server (Apache)' service stopped.
     
  2. Nataliya Zagr

    Nataliya Zagr Regular Pleskian

    21
    87%
    Joined:
    Apr 14, 2009
    Messages:
    242
    Likes Received:
    0
    Hello,

    Please, check the mail Apache log for the errors that could cause the issue:

    /var/log/httpd/error_log
     
  3. SavinV

    SavinV Guest

    0
     
    Hy Zagr, i don't have the folder httpd in /var/log.. I only have this two folders: apache2 and sw-cp-server.
    I checked the apache2 error.log file and i have a couple of warnings and errors..
    Looked at it but I don't know where exactly is the problem.. can u please point me to the right direction?
    I attached the 2 files with error log from apache2 and sw-cp-server here..

    The problem is strange..

    Problem Solved with the Name Servers.. i had to register my Name Servers at the International Registry to work with .com's, org's etc.
     

    Attached Files:

    Last edited by a moderator: May 29, 2009
  4. SavinV

    SavinV Guest

    0
     
    So no one knows what's the problem? :(
     
Loading...