1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

API :: Enable SpamAssassin for Email account

Discussion in 'Plesk for Linux - 8.x and Older' started by bmwbill42, Feb 18, 2010.

  1. bmwbill42

    bmwbill42 Guest

    Hello.. I have created the following function to enable the spam filter for an account:

    The results of the function are:

    After searching through the Plesk 8.4 API documentation I can't seem to find the correct way to enable the SpamAssassin feature on a selected mail account...

    Can anyone tell me what I'm doing wrong, it has to be with the XML request format.
  2. WallyB

    WallyB Guest

    From the look of the code you haven't closed off the packet node. Also, I believe the version should be at least And the username shouldn't have a domain name...
    <packet version=>
    This from the API-rpc 8.4 guide. Hope it helps.
  3. bmwbill42

    bmwbill42 Guest

    Thanks for pointing that out -- I did forget to close the <packet> node.

    with and without the $DomainName appended it succeeds with STATUS => OK, but when I check the account through the GUI the Spam Filter is not enabled for the account...

    What am I missing? And if its executing the command with STATUS => OK why is the spam filter not being enabled?
  4. bmwbill42

    bmwbill42 Guest

    Also if I change the packet version all I get are parse errors.. I'm running Plesk 8.4 on CentOS. Do I need to update the API component? Is that updated separately of Plesk itself?