• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Apostrophe in email address causes error with psa-pc-remote

Christopher McBride

Basic Pleskian
Whenever an email is sent where the recipient's address includes an apostrophe ('), an error is produced in the maillog:

an 20 09:59:31 server /usr/lib64/plesk-9.0/psa-pc-remote[16519]: Unable to prepare SQL statement for query 'SELECT executable, context, name FROM handlers WHERE queue=3 AND type='0' AND enabled=1 AND address='name.O'[email protected]' ORDER BY priority DESC': near "surname": syntax error

Can this be submitted as a bug to be resolved in a MU please?
 
Yes, it is known problem and we have already submitted related bugreport. I have updated it with your case and I hope it will be fixed soon.
 
Any update on this Igor?

Six months is a long wait to a fix for what, I'm sure, is a simple fix of changing single quotes to doubles for the query.
 
I have updated bugreport with your request. I hope that fix will be included into the one of microupdate.
 
Back
Top