1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Atmail search not working after upgrade to Plesk 10

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by PaulB1977, Nov 25, 2010.

  1. PaulB1977

    PaulB1977 Guest

    0
     
    After upgrading to Plesk 10, the search facility in Atmail stopped working. I found that there was a problem with the search.php file in the atmail directory which was appending '20' to the search date range years, even though they already had a leading 20. This was producing an IMAP query like this:

    FROM "test search" BEFORE "31-Dec-202011" SINCE "25-Sep-202010"

    To fix, edit search.php in the atmail directory (/var/www/atmail/search.php)

    Change Line 364: $before = "$BeforeDay-$BeforeMonth-$BeforeYear";
    Change Line 369: $after = "$AfterDay-$AfterMonth-$AfterYear";

    Hope this helps somebody.
     
  2. JoelR

    JoelR New Pleskian

    19
    30%
    Joined:
    Aug 28, 2009
    Messages:
    7
    Likes Received:
    0
    Thanks so much. Worked like a charm.

    Joel
     
  3. 1stjambon

    1stjambon New Pleskian

    19
    85%
    Joined:
    Jul 29, 2009
    Messages:
    11
    Likes Received:
    1
    Hey thanks a lot! I owe you a beer :p
     
Loading...