1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

autoinstaller fails after 10.1.1

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by fearz, Feb 14, 2011.

  1. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    Hi, saw the update, ran the update, first time gave errors, second time ran okay, then i ran yum update, asked to update mysql, then i updated, everything seems okay but whenever i try to re-run update i get this:

    Unable to start Parallels Products Installer. The following error has occurred: Unable to execute autoinstaller: autoinstaller: Unknown option in command string, see log for details

    autoinstaller runs fine from cmd

    i also noted this when trying to restart psa:

    /etc/init.d/psa restart
    /usr/local/psa/admin/bin/packagemng: unrecognized option `--set-dirty-flag'
    packagemng: Unknown option in command string, see log for details
    packagemng: Unknown option in command string, see log for details

    panel.log:

    2011-02-14T21:39:34+02:00 ERR (3): Unable to start Parallels Products Installer. The following error has occurred: Unable to execute autoinstaller: autoinstaller: Unknown option in command string, see log for details

    Centos5 32

    #uname -a
    Linux 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:53:09 EST 2011 i686 i686 i386 GNU/Linux
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    What about install updates with running autoinstaler in CLI:

    ?
     
  3. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    no errors from cli
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    If I correctly understood you have successfully updated your Plesk?
     
  5. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  6. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    Supposedly yes...
     
  7. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    I just noted that autoinstaller cmd has mySQL 5.1 unchecked, so i was trying to check it and run autoinstaller, received this:

    ERROR: Unable to proceed with the installation until the package mysqlclient15-5.0.90-1.el5.art.i386 is removed from the system.
    Not all packages were installed.
    Please resolve this issue and try installing the packages again.
    If you cannot resolve the issue on your own, contact product technical support for assistance.
     
  8. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    It seems i am unable to access any of the Tools & Settings...


    ERROR: PleskFatalException
    Up Level
    List interfaces failed: ifmng failed: ifmng: Unknown option in command string, see log for details
    0: common_func.php3:95
    psaerror(string 'List interfaces failed: ifmng failed: ifmng: Unknown option in command string, see log for details')
    1: IPAddress.php:583
    IPAddress::getInterfaces()
    2: class.IPAddressesList.php:68
    ipAddrList->fetchIPAddrList()
    3: cList.php:87
    cList->fetchList()
    4: cList.php:106
    cList->init()
    5: server.ip-address.php:115
    plesk__server__ip_address->accessItemList(string 'GET', NULL null)
    6: server.ip-address.php:58
    plesk__server__ip_address->accessItem(string 'GET', NULL null)
    7: UIPointer.php:595
    UIPointer->access(string 'GET')
    8: plesk.php:45

    Any suggestions?
     
  9. sahinler

    sahinler Basic Pleskian

    24
    73%
    Joined:
    Apr 26, 2007
    Messages:
    46
    Likes Received:
    0
    the package mysqlclient15-5.0.90-1.el5.art.i386 is removed from the system

    Hi IgorG,

    Please could you help me. I have this notification in my phpMyAdmin window:
    I want to install MySQL 5.1 but I have same lines like user fearz.

    My installation problem wasn't developped with Plesk Update, could you analyze with following lines installation steps with "CLI".

    /usr/local/psa/admin/sbin/autoinstaller

     
  10. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    Hi,

    What i did was replaced:

    /usr/local/psa/admin/bin/websrvmng - with the earlier/previous version

    root@:/usr/local/psa/admin/sbin# ls -la /usr/local/psa/admin/bin/websrvmng
    -rwxr-xr-x 1 root root 194601 Feb 18 13:55 /usr/local/psa/admin/bin/websrvmng
    root@:/usr/local/psa/admin/sbin# ls -la /usr/local/psa/admin/sbin/websrvmng
    -r-xr-x--- 1 root root 194601 Feb 15 21:21 /usr/local/psa/admin/sbin/websrvmng


    &

    /usr/local/psa/admin/sbin/wrapper - with the earlier/previous version

    root@:/usr/local/psa/admin/sbin# ls -la wra*
    ---s--x--- 1 root psaadm 16772 Feb 15 21:25 wrapper
    ---s--x--- 1 root root 194601 Feb 15 21:25 wrapper10.1.1

    That fixed this problem.
     
  11. sahinler

    sahinler Basic Pleskian

    24
    73%
    Joined:
    Apr 26, 2007
    Messages:
    46
    Likes Received:
    0
    My problem isn't fixed, unfortunaly I have always this :

     
  12. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Try to remove with force and nodeps mysqlclient15-5.0.90-1.el5.art.i386 package.
     
  13. guerramx

    guerramx Guest

    0
     
    I have the same exact issue, but guess what? I´m a newbie in servers and linux, so please I beg for the exact instructions to solve this cause didn´t get anything of your solution.

    Removing mysqlclient15-5.0.90-1.el5.art.i386 package will delete the databases stored on the server?

    Thanks in advance.
     
  14. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    No, databases will not be deleted. But it is very bad idea - install Plesk on server where you have already mysql databases in production.
     
Loading...