1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

autoresponder using .qmail-default

Discussion in 'Plesk for Linux - 8.x and Older' started by atin, Aug 11, 2005.

  1. atin

    atin Guest

    0
     
    We provide auto-responder service and for this we execute a script when any new mail arrives. We have done it using following lines in .qmail-default file (in our old server):
    |/home/httpd/vhosts/isendinfo.net/cgi-bin/subscribe34.pl

    It was working fine on old server, we tried to put these lines on our new Plesk 7.5 Reloaded server's .qmail-default file
    (/var/qmail/mailnames/isendinfo.net/.qmail-default) , but the script subscribe34.pl is not getting executed when any new mail arrives.

    Could you please give us some idea what we might be doing wrong.

    OR, if this is not possible this way, please let us know how we can do the same thing i.e. call a script when any new mail arrives.

    Thanks!
    Atin Kapoor
     
  2. mikk

    mikk Basic Pleskian

    23
    73%
    Joined:
    Jan 29, 2005
    Messages:
    83
    Likes Received:
    0
    Check that you have permissions to execute it as a non owning user.

    ie check that all directories up to and including the file are chmod to 755 and not 750
     
  3. atin

    atin Guest

    0
     
    Hey mikk .... thanks a lot buddy, it worked!!
     
  4. atin

    atin Guest

    0
     
    .qmail-default file problem

    Hi,
    This worked great before .... we are calling a autoresponder script (perl script) when any new mail arrives using the following code in .qmail-default file:
    |/usr/bin/perl /home/httpd/vhosts/domain.com/httpdocs/subscribe.pl

    This had correct permissions and was working perfectly ... not sure what happened, i just restarted qmail usign the following command /etc/rc.d/init.d/qmail restart .......... and now it stopped working.
    When i send a mail to the server, it bounces back with error as
    Sorry, no mailbox here by that name. (#5.1.1)

    Obviously there is no mailbox with that name, but we dont' want to send the mail to any mailbox, we just want to pipe it to a perl script.

    Can anybody give any idea.

    Best Regards
    Atin Kapoor
     
Loading...