1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Back Up Issues

Discussion in 'Plesk for Linux - 8.x and Older' started by razorack, Mar 5, 2005.

  1. razorack

    razorack Guest

    0
     
    I upgraded our server to 7.5.2 and then had one of our admins go in and set up backups on our clients domains. When ever the backup runs, it is somehow kiiling off apache and we get calls telling us that web sites are down.

    There is definately somthing wrong, as when we turn off backups the problem goes away. This is very annoying to say the least. Anyone have a fix?

    razorack---
     
  2. networkthinking

    networkthinking Guest

    0
     
    We've been seeing this too. Posted a few days ago but no response. In our case, it does not happen all the time or even on the same domain. Very sporadic but still frustrating.
     
  3. razorack

    razorack Guest

    0
     
    Networkthinking ,

    You are correct it does not always happen on the same domain or same time. This realy needs to be fixed, as we have to back up these sites and I do not want to have to use one of our custom backup scripts and have Plesk say that they cannot help us because we are using our own backup solution.

    razorack---
     
  4. evend1

    evend1 Guest

    0
     
    Hi there,

    we have the same problem.
    During dump the domain will be deactivatet. Thats ok because of locked files. But after the dump finished the domain ist not reactivatet. This just happens with one domain.

    And another Problem ist that some dumps failed. We have dumps which are just a few KB Big instad of hundrets MB. This doe not happen all the time.

    Hope somone from SW-Soft has answeress. Because our customer also acling us to tell that the domanis are down :-(


    Greetings

    Alex
     
  5. evend1

    evend1 Guest

    0
     
    Hello again.

    Until there will be a solution, you can enable a cronjob, which will start about 5 minutes after you startet the backup. Let this cronjob execute apachectl restart. That should minimize the problem for a while.
     
  6. justyxxxx

    justyxxxx Guest

    0
     
    I've been backing up, but haven't had this problem. I use the following command to backup my server:

    /usr/local/psa/bin/psadump -f - --nostop --nostop-domain --tar-ignore-failed-read --force | split -b1000m - /misc/psadump030605/

    But, before running the above, I run:
    service psa stop1

    And then after it's complete, I run:
    service psa start1
     
  7. networkthinking

    networkthinking Guest

    0
     
    Hello,
    I have found apachectl restart does not turn this back on. I have to run :
    /usr/local/psa/admin/bin/websrvmng -a -v

    to get his back up and running. Because of all the calls, I think we will disable the backups for now until we hear of a fix.

    Thanks,
    Wally
     
  8. justyxxxx

    justyxxxx Guest

    0
     
    Did you even try the backup command that I gave you?
     
  9. networkthinking

    networkthinking Guest

    0
     
    justyxxxx,
    I'm familiar with psadump and use occasionaly but want to focus on getting the individual domains to backup per the gui.

    Thank for helping on this.

    Wally
     
  10. ppuppy

    ppuppy Guest

    0
     
    I'm convinced this has to do with mysql [possibly simply the order in which services are started when "psa startall" is called].

    If (via ssh) I do "httpd stop" followed by "psa stopall" and then try "psa startall"- I get a few error messages and httpd is not started.

    The error messages are:
    ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    websrvmng: db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    websrvmng: db_connect: failed to connect to database: Error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    websrvmng: Unable to connect to the mysql database
    websrvmng: Unable to connect to the mysql database

    My guess is something similar is happening when backups are initiated via plesk control panel- and httpd winds up not being started after the backup.

    I can avoid these error messages (manually, in a shell) by simply starting mysqld first. E.g. - after stopping httpd and then "psa stopall", if I start mysqld and then "psa startall" - I see no error messages and httpd is started.

    I hope what I have observed will help others to shed some more light so we'll be able to fix this problem. Anyone have any ideas as to how to get httpd to start automatically after a plesk control panel initated backup?
     
  11. benc@

    benc@ Guest

    0
     
    Similar problems - different error?

    Hi,

    I am having problems with my backups not working correctly either... when I look in

    /var/log/psadump-2005-03.log

    I see:

    Mar 14 00:30:14 plesk.novatechnix.com psadump: Can't use string ("<?xml version="1.0"?><psa versio") as a symbol ref while "strict refs" in use at /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/XML/Parser/Expat.pm line 456.
    Mar 14 00:31:30 plesk.novatechnix.com psadump:


    These backups used to work fine, and then all of sudden stopped working.

    Anyone have this also? or know what I can do to resolve?
     
  12. ppuppy

    ppuppy Guest

    0
     
    Benc- the problem you speak of is a little different than the one we are talking about here.

    Check out this thread:
    http://forum.sw-soft.com/showthread.php?s=&threadid=22505

    I hope that helps you with your problem.

    Anyone else have any more advice/suggestions about getting httpd to start after initiating a backup in the control panel?
     
  13. yeploler

    yeploler Guest

    0
     
    how did you turn off ALL the backups?
    I've got the same problem, without any stable solution. But sometimes my server is still crashing without any warning, because of a backup-process (tar process which fails)

    I also deactivated the daily psa-db backups in the root cronjob...

    maybe there are still some client-backups... ?!


    best regards, loler
     
Loading...