1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Backup Fatal Error on 10.4.4

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by JMWebmaster, Nov 30, 2011.

  1. JMWebmaster

    JMWebmaster Guest

    0
     
    I paste here the error. I tried several times by rebooting the server, restarting psa, cleaning the dump folders. Checked storage and it's farly enough to take the backup. This error shows when trying to backup configuration, and configuration and content too. Can you help me?

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
      <execution-result status="error" log-location="/usr/local/psa/PMM/sessions/2011-12-01-031756.774/migration.result">
        <message id="f7aa2c9f-ca29-4896-84a0-f46c3f02d236" severity="error" code="fatal">
          <description>Runtime error</description>
        </message>
        <message id="32aa72c7-f5f3-4882-8b35-a58fcc528929" severity="error" code="CheckDump">
          <description>Unable to check dump: Could not check dump. Invalid xml response:  
     at /usr/local/psa/PMM/agents/PleskX/PmmCli.pm line 177
    	PmmCli::parseCheckDumpResult('Error: adjacent parameter is empty in \'dump-file-specificati...') called at /usr/local/psa/admin/bin/plesk_agent_manager line 1136
    	main::checkDump('/var/lib/psa/dumps', '', '/usr/local/psa/PMM/sessions/2011-12-01-031756.774') called at /usr/local/psa/admin/bin/plesk_agent_manager line 670
    	main::__ANON__() called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 415
    	eval {...} called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 407
    	Error::subs::try('CODE(0x15cb5b60)', 'HASH(0x15cb5f40)') called at /usr/local/psa/admin/bin/plesk_agent_manager line 679
    	main::perform('verbose', 4, 'owner-type', 'server', 'split-size', 'undef', 'session-path', '/usr/local/psa/PMM/sessions/2011-12-01-031756.774', 'description', ...) called at /usr/local/psa/admin/bin/plesk_agent_manager line 1210
    	main::__ANON__() called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 408
    	eval {...} called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 407
    	Error::subs::try('CODE(0x15359170)', 'HASH(0x16b703f0)') called at /usr/local/psa/admin/bin/plesk_agent_manager line 1219
    	main::main() called at /usr/local/psa/admin/bin/plesk_agent_manager line 1221.
    </description>
        </message>
        <message id="8e3a81e1-dd74-4726-8f7a-b1843bded07a" severity="error" code="fatal">
          <description>Unable to create dump</description>
        </message>
        <message id="bf2e9215-49f9-47f2-84e0-5b7a288ae11c" severity="error" code="UtilityError">
          <description>Unable to get Global settings for APS Applications (ErrorCode: 3, STDOUT:).</description>
        </message>
        <object name="difasa" type="client">
          <object name="difasa.com" type="domain">
            <message id="47d44f34-aaf3-456b-8982-20f290ffe2d8" severity="error" code="UtilityError">
              <description>Unable to get APS instances on webspace id 52 (ErrorCode: 1, STDOUT:).</description>
            </message>
            <object name="difasa.com" type="hosting">
              <object name="old.difasa.com" type="domain">
                <message id="b36cfd1e-fbea-4d15-87f0-f610c0a7b6f7" severity="error" code="UtilityError">
                  <description>Unable to get APS instances on webspace id 70 (ErrorCode: 1, STDOUT:).</description>
                </message>
              </object>
              <object name="blog.difasa.com" type="domain">
                <message id="db59cf4b-24f3-4b31-8f77-00fc7b7a5a4b" severity="error" code="UtilityError">
                  <description>Unable to get APS instances on webspace id 71 (ErrorCode: 1, STDOUT:).</description>
                </message>
              </object>
            </object>
          </object>
        </object>
        <object name="cienciaespacial.com" type="domain">
          <message id="63bc4a4a-1eb0-4e40-89b1-3247d2106132" severity="error" code="UtilityError">
            <description>Unable to get APS instances on webspace id 51 (ErrorCode: 1, STDOUT:).</description>
          </message>
        </object>
      </execution-result>
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Errors like
    indicates that you have database inconsistency. If you can't fix it by yourself in psa database I suggest you contact Parallels Support Team.
     
  3. JMWebmaster

    JMWebmaster Guest

    0
     
    I solved the APS problems. Now the first is the worst of all problems. Seems like a corrupt domain. Is there any plesk command to restore the integrity of a domain automatically?
     
  4. JMWebmaster

    JMWebmaster Guest

    0
     
    I think I've discovered something. In a recent version of Plesk, there was an improvement of the subdomain folder possibilities. Originally it was stored at the "subdomains" folder into it's domain folder but after that update the user can save a subdomain at any place even at the root folder of his domain.

    From what I have discovered, if a user saved a subdomain at the root directory of his domain using the apps tool to install, for example, a wordpress CMS automatically, it makes crash the Plesk's Backup tool at this point because the Backup tool looks for for the configuration files of that domain at the subdomain folder.

    I'll try to override that bug by rebuilding that subdomains and keep you updated.
     
  5. MarcoJ

    MarcoJ New Pleskian

    16
    60%
    Joined:
    Nov 7, 2010
    Messages:
    16
    Likes Received:
    0
    Also backups not working anymore

    Hi,

    any news here? I've the same problem, my server backups are not running anymore, if it's a backup to the local repository or to the FTP space.

    It seems to have appeared also after the 10.4.4 update, where all subdomains were "reorganized". But how can i find out what's going wrong here? I feel quite bad without my nightly backup :-(

    My error code:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
      <execution-result status="error" log-location="/opt/psa/PMM/sessions/2011-12-18-125247.632/migration.result">
        <message id="e6d4f0bd-5601-4304-8909-7f78058b1e8f" severity="error" code="fatal">
          <description>Runtime error</description>
        </message>
        <message id="b76802f7-5f6c-4fa4-8714-ed5b94555b89" severity="error" code="CheckDump">
          <description>Unable to check dump: Could not check dump. Invalid xml response:  
     at /opt/psa/PMM/agents/PleskX/PmmCli.pm line 177
    	PmmCli::parseCheckDumpResult('Error: adjacent parameter is empty in \'dump-file-specificati...') called at /opt/psa/admin/bin/plesk_agent_manager line 1136
    	main::checkDump('/var/lib/psa/dumps', '', '/opt/psa/PMM/sessions/2011-12-18-125247.632') called at /opt/psa/admin/bin/plesk_agent_manager line 670
    	main::__ANON__() called at /usr/share/perl5/Error.pm line 416
    	eval {...} called at /usr/share/perl5/Error.pm line 408
    	Error::subs::try('CODE(0x1daef38)', 'HASH(0x1e25e68)') called at /opt/psa/admin/bin/plesk_agent_manager line 679
    	main::perform('verbose', 4, 'owner-type', 'server', 'split-size', undef, 'session-path', '/opt/psa/PMM/sessions/2011-12-18-125247.632', 'description', ...) called at /opt/psa/admin/bin/plesk_agent_manager line 1210
    	main::__ANON__() called at /usr/share/perl5/Error.pm line 409
    	eval {...} called at /usr/share/perl5/Error.pm line 408
    	Error::subs::try('CODE(0x1c52ba8)', 'HASH(0x1c52c80)') called at /opt/psa/admin/bin/plesk_agent_manager line 1219
    	main::main() called at /opt/psa/admin/bin/plesk_agent_manager line 1221.
    </description>
        </message>
        <message id="15f5c39f-ec41-44ef-8aee-41bb3560efc1" severity="error" code="fatal">
          <description>Unable to create dump</description>
        </message>
        <message id="a5cacd29-191f-447e-8ea8-c553ef354134" severity="error" code="UtilityError">
          <description>Unable to get Global settings for APS Applications (ErrorCode: 3, STDOUT:).</description>
        </message>
      </execution-result>
    
    
     
  6. Sharkey

    Sharkey New Pleskian

    15
    85%
    Joined:
    Mar 18, 2011
    Messages:
    5
    Likes Received:
    0
    no backups with plesk 10.4

    I'm getting the same type of error. I can't find any thread with a solution listed. Could someone please provide an update? Thanks!

    My error:

    <?xml version="1.0" encoding="UTF-8"?>
    <execution-result status="error" log-location="/opt/psa/PMM/sessions/2011-12-21-114709.956/migration.result">
    <message id="cb134ca1-bcda-4f94-8457-6b561ab038d8" severity="error" code="fatal">
    <description>Runtime error</description>
    </message>
    <message id="d9e7bbc0-549c-478a-8069-4c9abc0ac629" severity="error" code="CheckDump">
    <description>Unable to check dump: Could not check dump. Invalid xml response:
    at /opt/psa/PMM/agents/PleskX/PmmCli.pm line 177
    PmmCli::parseCheckDumpResult('Error: adjacent parameter is empty in \'dump-file-specificati...') called at /opt/psa/admin/bin/plesk_agent_manager line 1136
    main::checkDump('/var/lib/psa/dumps', '', '/opt/psa/PMM/sessions/2011-12-21-114709.956') called at /opt/psa/admin/bin/plesk_agent_manager line 670
    main::__ANON__() called at /usr/share/perl5/Error.pm line 416
    eval {...} called at /usr/share/perl5/Error.pm line 408
    Error::subs::try('CODE(0x1e5e8a0)', 'HASH(0x1e61058)') called at /opt/psa/admin/bin/plesk_agent_manager line 679
    main::perform('verbose', 4, 'owner-type', 'server', 'split-size', undef, 'session-path', '/opt/psa/PMM/sessions/2011-12-21-114709.956', 'description', ...) called at /opt/psa/admin/bin/plesk_agent_manager line 1210
    main::__ANON__() called at /usr/share/perl5/Error.pm line 409
    eval {...} called at /usr/share/perl5/Error.pm line 408
    Error::subs::try('CODE(0x1c4b0e0)', 'HASH(0x1c4b1b8)') called at /opt/psa/admin/bin/plesk_agent_manager line 1219
    main::main() called at /opt/psa/admin/bin/plesk_agent_manager line 1221.
    </description>
    </message>
    <message id="0195dbb7-cc7a-4bbb-8115-c19f3c50ca0c" severity="error" code="fatal">
    <description>Unable to create dump</description>
    </message>
    <message id="c9e3bc09-4e2d-4cf4-81b1-96ecb036316f" severity="error" code="UtilityError">
    <description>Unable to get Global settings for APS Applications (ErrorCode: 3, STDOUT:).</description>
    </message>
    </execution-result>
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    The issue could be caused by some APS applications inconsistency in Plesk database. So you can check Plesk database and found that some applications do not have proper Uid with following SQL query:

    mysql> select id,cacheId,registryUid from smb_apsPackages;

    registryUid shouldn't be NULL. You can try to remove such records at least.
     
  8. Sharkey

    Sharkey New Pleskian

    15
    85%
    Joined:
    Mar 18, 2011
    Messages:
    5
    Likes Received:
    0
    A null entry was the problem in my case. Once the entry was deleted, backups began working again.

    Thanks.

    Mark
     
  9. MarcoJ

    MarcoJ New Pleskian

    16
    60%
    Joined:
    Nov 7, 2010
    Messages:
    16
    Likes Received:
    0
    Seems to solve also the backup problem in my case. I've had four "NULL" entries which i've removed (wherever these entries came from, but this is task of the dev team).

    First backup to server repo has worked OK, now backup to FTP repo running. Will report if there will be a problem (which i don't think actually)

    Thanks for the hint!
     
Loading...