1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

backup problem - ftp to remote ftp server

Discussion in 'Plesk for Linux - 8.x and Older' started by rustblack, Mar 12, 2005.

  1. rustblack

    rustblack Guest

    0
     
    [​IMG]

    RH9, PLESK 7.5.2, all Plesk patches installed as of March 2005

    The server will not backup to a remote ftp server. it logs in, cwd's to the correct directory, but does not write any backup files.

    The error is attached. unable to create the backup file ftp curl execution ftp_filemng process.

    I am able to create directories using the same ftp account from the Plesk server from a command line, so write is enabled on the remote ftp directory. remote ftp server logs show no errors.
     
  2. rustblack

    rustblack Guest

    0
     
    My bad. FTP server was runninig Windows SP2 firewall. Although the Plesk server was trusted, something was preventing it from writing to the Windows box.
     
  3. clintsulis

    clintsulis Guest

    0
     
    Plesk FTP Backup Problem Solved

    I was having this same problem and managed to fix it today. I was receiving the exact error messages posted at the top of this thread. I am using Plesk Unloaded v7.5.3 on Fedora and have Filezilla v0.9.27 running on Windows 2003 Server.

    Our company has ComCast business grade Internet service, so if we want to host any services we need to login to our router and map ports using Network Address Translation (NAT). Therefore, I configured ports 20-21 TCP/UDP to forward to my file server 10.0.0.2 which is a non-routable IP address. This did not work, and after much poking around I discovered that FileZilla has a few Passive (PASV) mode settings. Their explanations is as follows...

    "Use custom PASV settings if you are operating the server from behind a NAT router or a firewall. In that case, the IP address of the server is not accessible from outside of the router, so you should fill in the correct address here. Use the port range to limit the number of ports that will need to be forwarded through the router."

    So I set the external IP address of my ComCast connection as the IP address FileZilla should use when performing PASV file transfers. I set a custom port range as well, and tried to setup the cable router to forward these ports as well. Unfortunately this only made PLESK timeout faster...

    I knew I was onto something here, so I just decided to go for broke and put the server in the DMZ. Essentially I stopped using NAT to forward FTP from the cable router to the file server. This fixed the problems immediately and PLESK FTP Backups now run flawlessly.

    The bottom line here is if you are having problems with PLESK FTP Backups, and the remote FTP server is behind a firewall or behind a router using NAT, you need to either setup port forwarding, firewall, and FTP Server PASV settings correctly (i failed to do this) or hang your FTP server's butt out on the Internet with nothing in front of it to mess up the PASV FTP transfers.

    I realize this is not very technical but with the lack of good responses to this issue I thought i'd better post something.
     
Loading...