1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Backup process has failed for domain 'example.com'

Discussion in 'Plesk for Linux - 8.x and Older' started by voltaq, Mar 13, 2005.

  1. voltaq

    voltaq Guest

    0
     
    I'm getting this error when I run a dialy backup. I think since I updated to Plesk 7.5.2
    I backup to a FTP-server I got.
    Does anyone know about this problem?
    I saw this problem at another thread. They solved the problem using bash: http://forum.sw-soft.com/showthread.php?s=&threadid=15238
    I want to use the backup the normal way.
    Code:
    START LOGGING: Sun Mar 13 04:35:14
     
     Postgres is not configured: all postgres databases will not be dumped.
     
     ===============================================================================
     
     Making backup to STDOUT ...dumping crontab of example_user
    
    Thanks in advance,
    voltaq
     
  2. ppuppy

    ppuppy Guest

    0
     
    I had a similar problem today-here is what happened and what my solution was.

    My server had plesk 7.5.1 installed without plesk bu. I tried to install bu. First, I set my mysql admin p/w to 'setup'. and then tried
    Code:
    rpm -Uvh psa-bu-7.5.1-rh9.build75041216.14.i586.rpm
    There were messages during that rpm install -specifically when the install script tried to "Generate public/private keys pair for server ...". The messages complained about not being able to connect to mysql.

    At that point, I tried a backup via plesk control panel- and I saw the same problem you did. I also noticed that http was now no longer working for the domain [could not load the domain's home page in browser -maybe related to http://forum.sw-soft.com/showthread.php?s=&threadid=22321].

    ------------------------------------------------
    My SOLUTION to your problem:
    1) via ssh, I unistalled bu [remember that I have 7.5.1- you have 7.5.2 and I don't know what arch you have]
    Code:
    rpm -e psa-bu-7.5.1
    2) I changed mysql admin password to match the plesk admin's password (i.e. NOT 'setup')
    3) I reinstalled bu
    Code:
    rpm -Uvh psa-bu-7.5.1-rh9.build75041216.14.i586.rpm
    ...this time with the right admin pw I did not get an error message when generating keys
    ------------------------------------------------

    Backup now completes successfully from control panel - but http still goes down and does not come back up after backup. [I can get http working again if do "psa stopall", then "mysql start", then "psa startall"- but I sure would like it better if http did not go down]
     
  3. ppuppy

    ppuppy Guest

    0
     
    A side effect of my solution above is that it took care of another error message. While I was getting the same message voltaq showed in his post above (that message came to me in email with subject "Backup process has failed for domain..."); I also was seeing an error message in /var/log/psadump.2005-03.log

    That error message was:
    Mar 13 14:50:42 myserver.com psadump: Can't use string ("<?xml version="1.0"?><psa versio") as a symbol ref while "strict refs" in use at /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/XML/Parser/Expat.pm line 456.

    After applying my solution above
    a) the email subject now says "Backup process has completed for domain...",
    b) no new error messages are appearing in /var/log/psadump.yyyy-mm.log
    c) the backup is actually being created now

    [the original problem was causing the backup to fail, so it was not even being created]
     
Loading...