1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Backup to ftp-repository: Failed to write testdata ... delete error:RETR failed: 425

Discussion in 'Plesk for Linux - 8.x and Older' started by azur99, Jan 3, 2007.

  1. azur99

    azur99 Guest

    0
     
    I receive this error when trying to set the account for the ftp-repository:

    Schreiben der Testdaten auf FTP-Account ftp://backupxxx.pureserver.info/ fehlgeschlagen:delete error: RETR failed: 425

    i've seen this error mentioned in other posts here and here
    but no solution so far.

    until now i checked that

    1. login-data is OK and login to the ftp-server is successfull (by using a non existing target directory which results in the expected error message: Couldn't CWD to test5)
    2. by experimenting with other ftp-servers i found out that the test routine writes a dummy file with a random name to the server (i.e _52dccb9fcf1fcd304e3d3b9e88f832b9) and
    3. i have verified i can send, retrieve and delete such files to the backupserver manually, so it cannot be due to forbidden filenames.


    anybody having the same problem or a solution?



    backupserver is a 1und1 server-backup space and ftp-backups did work until the last upgrade.
    PS:by the way even a ftp-account on an other pleskserver gives an error: failed to ... FTP response timeout.
     
  2. DReffects

    DReffects Basic Pleskian

    26
    40%
    Joined:
    Feb 8, 2005
    Messages:
    76
    Likes Received:
    0
    same thing here...

    this is ****in annoying.. since i've upgraded to 8.x NOTHIGN in terms of backups work... wasnt able to do a backup for ages now ://

    heres what i get:

    PHP:
    TemporaryError421 No Transfer Timeout (600 seconds): closing control connection.
    Debugging infoftputil 2.1Python 2.4.1 (linux2)
    thats rediciolous... the ftp server works just fine...
     
  3. LSchneck

    LSchneck Guest

    0
     
    I've the same problem with my server after update tu 8.1
    It's strange because the ftp accounts which existed before the update work fine. But I can't create a new one

    The effect is the same as yours

    no idea

    gretings

    Lothar
     
  4. DReffects

    DReffects Basic Pleskian

    26
    40%
    Joined:
    Feb 8, 2005
    Messages:
    76
    Likes Received:
    0
    i've just did the impossible^^ i've backed up my domain. the only odd thing is:

    the backup seems to work with NO VOLUME SPLITTING - in my case a handy 47GB Backup archive wich transfers just fine to the ftp...

    i am curious: does backup work for you with a SINGLE file too?
     
  5. Highland

    Highland Guest

    0
     
  6. DReffects

    DReffects Basic Pleskian

    26
    40%
    Joined:
    Feb 8, 2005
    Messages:
    76
    Likes Received:
    0
    hmm good effort but /usr/local/psa/bin/pleskbackup doesnt work either with me...
     
  7. masterkain

    masterkain Guest

    0
     
    same problem here, ridiculous
     
  8. pollyx

    pollyx Guest

    0
     
    Same thing here with Plesk 8.1.0

    Error: Failed to write test data to the FTP account ftp://backup.serverkompetenz.de//: delete error: Timeout while waiting for server connect

    When leave the directory field blank, Plesk goes into an endless loop.

    Ridiculous...
     
  9. Landyphil

    Landyphil Guest

    0
     
    Hello,

    here exist the same Promlem after the Update to 8.1. It is not possible to create a new backuproutine.

    My Provider tells me that this Plesk 8.1 Bug is a known problem. Up to know there is no Release or comment from sw soft, i believe this will not be fixed in 2 weeks.

    I´m not going to write my own backuproutines, why do i have choosen for an Provider with Plesk?

    Actualy I´m thinking about a downgrade back to to 8.01

    Stil hopefully waiting to a bugfix release ;-)

    Phil
     
  10. SlowMo

    SlowMo Guest

    0
     
    Fixed Backup Problem...

    Backup Problem:

    Failed to write test data to the FTP account ftp://backupXXX.xxxxxxxx-server.info/: delete error: RETR failed: 425.


    To correct this problem,

    1. Delete Tasklock /usr/local/psa/var/backup_tasks_mng.lock

    2. Edit & Execute following SQL-Script:

    # Enter your own Settings in the INSERT-Statement first
    # <host>
    # <login>
    # <directory>
    # <password>


    USE `psa`;

    #
    # Structure for the `BackupsSettings` table :
    #

    DROP TABLE IF EXISTS `BackupsSettings`;

    CREATE TABLE `BackupsSettings` (
    `id` int(10) unsigned default NULL,
    `type` enum('domain','client','server') NOT NULL default 'domain',
    `param` varchar(255) character set utf8 NOT NULL default '',
    `value` varchar(255) character set utf8 default NULL,
    UNIQUE KEY `index1` (`id`,`type`,`param`)
    ) ENGINE=InnoDB DEFAULT CHARSET=latin1;

    #
    # Data for the `BackupsSettings` table (LIMIT 0,500)
    #

    INSERT INTO `BackupsSettings` (`id`, `type`, `param`, `value`) VALUES
    (1,'domain','backup_ftp_settingtab','ftp'),
    (1,'domain','backup_ftp_settingsplit_size','0'),
    (1,'domain','backup_ftp_settinghost','<host>'),
    (1,'domain','backup_ftp_settinglogin','<login>'),
    (1,'domain','backup_ftp_settingdirectory','<directory>'),
    (1,'domain','backup_ftp_settingpassword','<password>');

    COMMIT;


    It worked fine for me :)

    SlowMo
     
  11. waxson

    waxson Guest

    0
     
    Not sure if this will help anyone else out there, but I had a similar problem and it drove me nuts! After quite a bit of digging around, this was how I solved it.

    First of all, do this quick test. Use ncftp (or equivalent) to FTP into your FTP repository and list the contents of the directory:

    ncftp -u myftpuser myftpserver.mydomain.com
    User myftpuser logged in.
    Logged in to myftpserver.mydomain.com.
    ncftp / > ls

    If the next two lines say something like this:

    connect failed: No route to host.
    Falling back to PORT instead of PASV mode.

    then the solution below may help you.

    This message is "caused" by overly restrictive IPTables/Firewall setings on the FTP server which appear to be installed on Plesk by default. (Side note - my FTP server also has Plesk on it) It prevents the FTP connection from operating in passive (PASV) mode which appears to be a requirement of the Plesk backup component. To fix, you need to relax your firewall settings slightly.

    There are at least two ways that you can do this. Firstly, you can go and figure out exactly what needs to be "relaxed" in your firewall connection, or you can simply make your FTP server allow all connections from your Plesk server. The first option is more secure, the second option is easier. Look at what's best for you, however for my server setup, the latter option is fine.

    To implement the latter option, go to your FTP server and edit /etc/sysconfig/iptables, find the following line:

    -A RH-Firewall-1-INPUT -i lo -j ACCEPT

    and add the following line directly underneath it (using the IP address of your plesk server):

    -A RH-Firewall-1-INPUT -s x.x.x.x -j ACCEPT

    Restart iptables and do the NCFTP login test described above. If you don't see the error message, then chances are that your problem has been solved.

    Good luck!

    Cheers
    Steve
    www.waxsonit.com.au
     
  12. waxson

    waxson Guest

    0
     
    Further to my previous response, a **better** way to fix this problem is to add the following setting:

    IPTABLES_MODULES="ip_conntrack_ftp"

    to the following file:

    /etc/sysconfig/iptables-config

    Restart iptables and the problem should be fixed.

    Cheers
    Steve
     
  13. azur99

    azur99 Guest

    0
     
    problem solved with 8.1.1 update

    the problem seems to be fixed with the latest plesk-update (8.1.1).
    GUI account definition and backup to ftp-repository works now without any errors.
     
  14. niamoman

    niamoman New Pleskian

    22
    57%
    Joined:
    May 17, 2007
    Messages:
    12
    Likes Received:
    0
    I see Plesk doesn't look on first slash - it takes user home DIR as base path anytime.

    If you have backupDIR outside user homeDIR, you can make symlink to that in user homeDIR.

    It works for me (Plesk 8.1.1).
     
Loading...