1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

big problem with multiviews

Discussion in 'Plesk for Linux - 8.x and Older' started by viktorf, Aug 10, 2005.

  1. viktorf

    viktorf Guest

    0
     
    I'm desperate... Multiviews wont work on my Linux server with Plesk (works fine on a non-Plesk machine).

    I want to use Multiviews to make the URL more user and search-engine-friendly (ie not .../page.php?id=1&cat=2 but .../page/title/2).

    The machine runs multiple virtual hosts, im trying to set on of them to use Multiviews.

    I have tried the following:
    add the following line to the proper vhost.conf:

    <Directory /home/httpd/vhosts/<domainname>/httpdocs>
    AllowOverride All
    </Directory>

    in the directory where i want the Multiviews to work, i created a .htaccess with the following:

    Options MultiViews

    I have also tried
    Options +MultiViews
    and
    Options Indexes FollowSymLinks MultiViews All

    The .htaccess als consist of the following directives (in order to parse specific files)

    <files page>
    ForceType application/x-httpd-php
    </files>

    The files directive works fine, but it wont use Multiviews... This setup works fine on a server without Plesk. I've used exactly the same method, except for the fact that i put these settings directly in the httpd.conf.

    Does anyone have a clue... i've been trying all day now...
     
  2. hardweb

    hardweb Guest

    0
     
    Add the particular options to the vhost.conf file and make sure that it's included in the domain httpd.include. You can regenerate the file files with:

    /usr/local/psa/admin/bin/websrvmng -u --vhost-name=domainname

    The .htaccess include files may not work, depending on your server configuration.
     
  3. viktorf

    viktorf Guest

    0
     
    Thanks, but that I have allready done.. the vhost.conf is working fine.

    I'm happy to say that I have found the solution:

    Apparently the Apache setup defaults to: "AcceptPathInfo Off"...
    (Strange though... I can't find a setting in any .conf, probably its some sort of compiling option???).

    Adding AcceptPathinfo On to vhost.conf solves it. (Too bad it took me a day and a night :eek: .
     
  4. snm13

    snm13 Guest

    0
     
    AcceptPathinfo syntax how?

    I still can't get apache to recognize AcceptPathinfo On
    I tried adding it to vhost.conf both inside the <Directory>
    ....
    </Directory>
    and outside it.
    and applying websrvmng and apache restart
    no help.

    I tried putting AcceptPathinfo in .htaccess no help.

    How exactly did you enter AcceptPathinfo in vhsot.conf to get it working?
     
Loading...