1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Block Access to Domain and all web users via http

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by RolandE, Sep 22, 2010.

  1. RolandE

    RolandE New Pleskian

    15
    85%
    Joined:
    Sep 22, 2010
    Messages:
    8
    Likes Received:
    0
    Apologies if I posted this in the wrong forum originally. :)

    Hello,

    I have a client who wishes to run one account on plesk purely for FTP (as network drives on Windows). The plesk web user interface is ideal for them as it makes it very easy to create ftp accounts in this way (without my involvement).

    However, I need to block all http traffic to this domain and web users directories. I can't password protect them all because they will be created without my involvement. I have therefore tried to add the following to vhost.conf in the domain's conf directory:

    <VirtualHost *IP address here*:80>
    <Directory /var/www/vhosts/*my domain here*/httpdocs/>
    Options None
    AllowOverride None
    Order deny,allow
    Deny from all
    </Directory>
    </VirtualHost>

    I reboot Apache and it makes no difference - whether I specify a web user's folder, the main httpdocs folder, with or without the Virtualhost tags.

    I am assuming this is the way to achieve this result but I am open to suggestions. Hopefully someone can advise.

    Thanks,


    R.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    What about something like

     
  3. RolandE

    RolandE New Pleskian

    15
    85%
    Joined:
    Sep 22, 2010
    Messages:
    8
    Likes Received:
    0
    Hello,

    Thanks for your reply, unfortunately it doesn't seem to do anything. Initially it conflicted with my vhost.conf edits. I removed those, reran the command and rebooted apache - doesn't seem to restrict access in any way.

    Any more ideas?

    R.
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Could you please describe it with more details - do you need fully disabled web service (http port 80) or you want that it worked, but has been protected?
     
  5. RolandE

    RolandE New Pleskian

    15
    85%
    Joined:
    Sep 22, 2010
    Messages:
    8
    Likes Received:
    0
    Hi.

    I would be happy with http completely blocked on that account only. It also needs to block any web user directories (eg. www.domain.com/~mike/) by default.

    All other domains on Plesk need to run normally. It's just this account where I want the customer to use the FTP facilities but with no corresponding website/web access.
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Did you
    after creating your vhost.conf ?
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  8. RolandE

    RolandE New Pleskian

    15
    85%
    Joined:
    Sep 22, 2010
    Messages:
    8
    Likes Received:
    0
    Hi. Thanks for your help. In the end, once I'd called in the new vhost.conf as per your post, the following worked:

    <Directory /var/www/vhosts/domain.com/httpdocs/>
    Options None
    AllowOverride None
    Order deny,allow
    Deny from all
    </Directory>
     
Loading...