1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Bug? File is below active open_basedir setting, but not seen by php

Discussion in 'Plesk for Linux - 8.x and Older' started by gecon, Sep 20, 2006.

  1. gecon

    gecon Guest


    I'm dealing with a problem related to php and the open_basedir setting.
    Running Plesk 8.0.1.

    The error I'm getting when requesting a web page is is a typical: "open_basedir restriction in effect."
    but there seems that this shouldn't happen, since the requested file is below the defined directories in open_basedir restriction.

    Here are some details.

    In file:

    there is:

    <IfModule sapi_apache2.c>
                    php_admin_flag engine on
                    php_admin_flag safe_mode off
                    php_admin_value open_basedir "/var/www/vhosts/asite.com/httpdocs:/tmp"
    and there isn't any vhost.conf file in:

    I'm requesting by using a browser the following:
    which gives the following error:

    The line 5 of the php source code (file: /var/www/vhosts/asite.com/httpdocs/admin/modules/action_products.php) in which the warning is given is just a:
    and the file:
    exists (it is in the same directory with the file making the include and below the allowed paths in open_basedir).

    What might be wrong?
    From the warning it seems like the
    generates a requests for: /action_products_view.php
    (in site's root directory) - not a relative to the existing request.

    Has anyone seen this and fixed this?
    I don't want to remove the open_basedir restriction (by setting it to 'none' or to '/'). Any ideas?

    Thank you.