1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Bug in FCGI support via web panel?

Discussion in 'Plesk for Linux - 8.x and Older' started by ash113, Mar 18, 2008.

  1. ash113

    ash113 Guest

    0
     
    When you enable FCGI support via the panel in Plesk 8.3, it sets up the following in the site's apache conf:

    Code:
            <IfModule mod_fcgid.c>
                    AddHandler fcgid-script .fcgi
                    Options +FollowSymLinks +ExecCGI
            </IfModule>
                    Options -Includes -ExecCGI
    
    The problem being that the line at the end, which is presumably the default, immediately turns off ExecCGI that had been turned on one line earlier. Leaving .fcgi files giving 403 errors. This can be fixed by adding a .htaccess that turns it back on, but that seems an unnecessary hoop to jump through. I'd think the right fix is for Plesk to set the default line at the top of the VirtualHost block, not the bottom, so that the various overides that might get turns on work properly.
     
  2. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    I have tested this functionality on Plesk 8.3.0 with January 31st update installed and noted following configuration change:

    <IfModule mod_fcgid.c>
    AddHandler fcgid-script .fcgi
    Options +FollowSymLinks +ExecCGI
    </IfModule>

    No line with disabling the option.
     
Loading...