1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

BUG Plesk 10.1.1 - can't create database user / dbusername field disabled

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by mivogtLU, Jul 26, 2011.

  1. mivogtLU

    mivogtLU New Pleskian

    12
    85%
    Joined:
    Jul 26, 2011
    Messages:
    5
    Likes Received:
    0
    Hi there,

    I am using a Plesk 10.1.1 installation on a 1&1 rootserver (Suse Linux).
    Since the last current update to 10.1.1 (no newer available here) I am unable to create a databaseuser.

    I am able to create databases for any customer.
    If I select the database and select the middle butten to create a db user I get the form to fill for db-user creation.

    The field to enter the db-user-name seems to be disabled. I can not fill in a username to be created.
    The passwordfields are working fine.

    I assured it is no browser problem (testes with windows and linux machines, IE and Firefox).

    My hosting-provider is not able to help me solve the problem.

    So hopefully someone on here may know a sulution/bugfix/patch/workaround.

    I am able to connect in a root shell - so if there is any command line option to generate a database-user in a plesk conform and compatible manner I am ready to type it in.

    HELP PLEASE !

    Thanks in advance

    Michael
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    First of all make sure that you have permissions for creation database users in corresponding subscriptions or user's roles. Also try to create it with CLI utility:

    # /usr/local/psa/bin/database -c database_name -add_user dtabase_user -domain domain_name
     
  3. mivogtLU

    mivogtLU New Pleskian

    12
    85%
    Joined:
    Jul 26, 2011
    Messages:
    5
    Likes Received:
    0
    Thanks, Igor,

    I am logged in as admin so I am with all permission I guess.

    Could you please provide an example for the CLI usage?

    If I try (option -u as I already did create the database with plesk panel)

    /usr/local/psa/bin/database -u <existingdatabasename> -add_user <newdbusername> -domain <existingdomain4dv> -passwd <XYZ1234> I get an error

    Wrong syntax for option's '-add_user' parameter







    ______________
    Version: 10.1.1_build1010110120.18 os_SuSE 11.0
     
  4. mivogtLU

    mivogtLU New Pleskian

    12
    85%
    Joined:
    Jul 26, 2011
    Messages:
    5
    Likes Received:
    0
    I believe I've found a part of the bug my problem is based on.
    Plesk 10.1.1 autogerates a usernameprefix i.e. myCustmerNameField folowed by _ (underscore) follwed by a dbusername-suffix to be entered.

    Using the Plesk 10.1.1 web-form I can not enter a username.
    Using the CLI with a username as suggested leads to an error on the user-creation

    If I use a shorter username with no underscore it works perfect.

    hope this helps to get closer to a permanent solution.

    Thanks again

    Michael
     
Loading...