1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can Not Change Shared IP's Default Domain

Discussion in 'Plesk 11.x for Linux' started by Arby L, Jul 19, 2012.

  1. Arby L

    Arby L Guest

    0
     
    Hi there,

    I've got Plesk 11.09 on RedHat 6.2. As I'm trying to change my "Shared" IP's default domain, Plesk will update and display the new default; however, once IP is accessed through the browser the old domain is displayed.

    I have tried the following with no luck:

    - Restart Apache
    - Reboot
    - I tried removing the subscription of the old default that didn't work. Then I changed the new default to another and it worked but now it is stuck on that and now I unable to change that.

    Note: browser catch has been cleaned on every step.

    In advance, I appreciate your help.

    Thank you,
    Arby L
     
    Last edited by a moderator: Jul 19, 2012
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    You need to disable Nginx for that to work :)
     
  3. Arby L

    Arby L Guest

    0
     
    abdi thanks for your reply. However, it has already been assigned a default. It's just that when I try to reassign a new one plesk will update it but through http it is not.

    I read some posts about nginx but I'm not sure if that applies here. Nevertheless, how do I check if nginx is enabled?

    PS. Parallels, is looking into it also but it's rather a slow process.

    Thank you,
    Arby L
     
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Arby, Yes the changes dont take effect if you are running Nginx. You can disable Nginx by going to:

    Tools & Settings -> Service Components -> ....

    Or by running the command below on SHELL

    /usr/local/psa/admin/bin/nginxmng --disable
     
  5. Arby L

    Arby L Guest

    0
     
    abdi, my server doesn't have nginx installed. I didn't think apache and nginx could be running at the same time. But I did try what you suggested and it errors out saying "Error: Nginx component doesn't installed". I personally think the person who wrote the errors should double check their work for grammatical errors, but that's a secondary issue here ;)

    Is there anything else you can think of?

    Thank you,
    Arby L
     
  6. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    OK, one last one, had you tried rebuilding the vhosts? You can do that with

    /usr/local/psa/admin/sbin/httpdmng --reconfigure-all

    Please let me know if that also doesnt resolve the problem ...
     
  7. Arby L

    Arby L Guest

    0
     
    Apparently there is a known issue from 10.4 which has not been resolved in 11.09.

    Here is the article about it: http://kb.parallels.com/en/114287

    Thanks for you efforts abdi.
    Arby L
     
Loading...