1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Cannot access plesk panel ...:8443

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Kevin Medri, May 14, 2010.

  1. Kevin Medri

    Kevin Medri Guest

    0
     
    All I get is the following error:

    ERROR: SWKeyExFatalError
    error: Cannot open file
    0: common_func.php3:4536
    of_get_key_by_product(string 'plesk-unix')
    1: common_func.php3:4536
    getPleskKey()
    2: common_func.php3:4615
    getKeyProp(string 'demo')
    3: auth.php3:48

    I have checked permisions:

    # ls -l /etc/sw/keys/
    total 28
    drwxrws--- 2 psaadm swkey-data 4096 Jan 6 14:55 backup
    -rw-r--r-- 1 psaadm swkey-data 22 Oct 16 21:25 info
    drwxrws--- 2 root swkey-data 4096 Oct 22 05:15 instances
    drwxrws--- 2 psaadm swkey-data 4096 Jan 6 14:55 keys
    drwxrws--- 2 psaadm swkey-data 4096 Oct 22 05:15 lock
    -rw-rw---- 1 root swkey-data 6101 Jan 12 01:43 registry.xml
    drwxrws--- 2 psaadm swkey-data 4096 Oct 22 05:18 restart

    I can stop and start plesk in ssh, just cannot access the panel?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Make sure that key file in /etc/sw/keys/keys directory has psaadm owner but not root.
     
  3. Kevin Medri

    Kevin Medri Guest

    0
     
    Any Ideas

    Its been two days now without access to my Plesk Panel, does anyone have any ideas?
    Thank you.
     
  4. coolemail

    coolemail Basic Pleskian

    20
    57%
    Joined:
    Feb 25, 2010
    Messages:
    44
    Likes Received:
    0
    Check and see if plesk is able to start with this shell command:

    /etc/init.d/psa restart

    Plesk is incompatible with an openssl upgrade that Centos and Redhat put out last month and if you arent running all of Plesks hotfixes I know parts of Plesk will not start.

    We did the fix at http://kb.odin.com/en/8338 which then got us back in. (A thread which led to this is at https://www.atomicorp.com/forums/viewtopic.php?f=18&t=4132)
     
  5. Kevin Medri

    Kevin Medri Guest

    0
     
    Thanks for that, the patch is already installed, I can stop and start plesk from ssh fine, just cannot access the panel?
     
  6. Kevin Medri

    Kevin Medri Guest

    0
     
    Not sure if its related, but I seem to be receiving 2 empty emails every 5 mins to the admin email address as well, hundreds over the last couple of days all being rated 8.9 by spam assassin and ending up in my spam folder.
     
  7. coolemail

    coolemail Basic Pleskian

    20
    57%
    Joined:
    Feb 25, 2010
    Messages:
    44
    Likes Received:
    0
    Sorry, I'm not sure what your issue might be. When we'd done an upgrade, we could not start Plesk even from Shell and the patch fixed it for us. Sorry we could not have been more help. Cannot advise on the blank emails that you are getting. Silly question, but have you tried a server reboot?
     
  8. Kevin Medri

    Kevin Medri Guest

    0
     
    Hi, yes I have rebooted a couple of times, I get this in sw-cp-server log file:

    2010-05-17 22:54:54: (connections.c.299) SSL: 1 error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
    2010-05-17 22:54:54: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2010-05-17 23:09:49: (log.c.135) server stopped
    2010-05-17 23:10:52: (log.c.75) server started
    2010-05-17 23:10:52: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    2010-05-17 23:10:52: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
     
  9. Kevin Medri

    Kevin Medri Guest

    0
     
    Not sure where to go from here, I have checked and corrected permissions at /etc/sw/keys/keys psaadmin I have checked the fix http://kb.odin.com/en/8338 I have a newer file already installed, I have rebooted the system several times from within virtuosso, I have stopped and started psa using ssh.
    I am now receiving resource limit exceed emails on a domain I am building a site on, which is strange because I have not worked on it for a week or so. It is really annoying not being able to access plesk, especially since it is a commercial panel. I know I am a newbie, and have limited knowledge in this area, however I thought maybe a Parallels tech could help??
     
  10. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    You have different issues and we can only suggest you something in forum's format. As you know forum is place for discussion and if our suggestions can't help you it means that problem should be investigated much more deeply and fixed directly on your server. Therefore you should contact Parallels support team in this case.
     
  11. Kevin Medri

    Kevin Medri Guest

    0
     
    Hi IqorG,
    Do you have the support teams contact info, thank you.
     
  12. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  13. philip mateo

    philip mateo Guest

    0
     
    404 on plesk panel

    Hi All,

    I'm also getting the same thing. I had plesk set up on a server a couple of months ago (around early March). It was still working the last time I accessed the Plesk panel page (https://myhostname:8443). I get a 404 error, I even tried the fix already and am also already using a more recent sw-cp-server package but no cigar.

    I get this from my error_log:
    2010-06-03 21:17:49: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2010-06-03 21:18:18: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2010-06-03 21:18:46: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2010-06-03 21:19:15: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2010-06-03 21:19:43: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2010-06-05 11:35:42: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure
    2010-06-05 11:41:13: (connections.c.299) SSL: 1 error:140780E5:SSL routines:SSL23_READ:ssl handshake failure

    @Kevin
    were you able to get this resolved?
     
  14. Kevin Medri

    Kevin Medri Guest

    0
     
    Hi Philip,
    I did not resolve the issue, after tech support looked at it and could not work out the issue, the only option was to do a container (I have virtuozzo) restore, this (in my case) can only be done by the VPS host company. Hope this helps.
    Kev
     
  15. m0rpheu5

    m0rpheu5 Regular Pleskian

    27
     
    Joined:
    Jul 1, 2008
    Messages:
    120
    Likes Received:
    0
    same problem here, and i still don´t find any fix to this problem, and the worst is that my license is expiring and i can´t retrieve keys because i got this error.

    Thanks
     
  16. kaizer

    kaizer Guest

    0
     
    This issue was solved by updating to 9.5.x.

    What if you try to run the autoinstaller from SSH and check for missing packages?
     
  17. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Just login via SSH and run something like

     
  18. m0rpheu5

    m0rpheu5 Regular Pleskian

    27
     
    Joined:
    Jul 1, 2008
    Messages:
    120
    Likes Received:
    0

    running this, i got this message

    [root@br02 ~]# /usr/local/psa/admin/sbin/autoinstaller --upgrade-installed-components
    File downloading products.inf3: 100% was finished.
    File downloading plesk.inf3: 11%..21%..37%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading ppsmbe.inf3: 18%..29%..40%..61%..71%..100% was finished.
    File downloading sitebuilder.inf3: 12%..25%..38%..64%..77%..100% was finished.
    File downloading setemplates.inf3: 24%..49%..74%..100% was finished.
    Checking for installed packages...
    ERROR: You did not select any version.

    And know? i´m already running Plesk 9.5.2.

    thanks
     
  19. m0rpheu5

    m0rpheu5 Regular Pleskian

    27
     
    Joined:
    Jul 1, 2008
    Messages:
    120
    Likes Received:
    0
    I have done the update by plesk and appears to work, so when i click in retrieve keys, appears that my license is terminated, now i´m verify with the company that sell the license to me, thanks
     
Loading...