1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

can't disable domains on 7.5.5

Discussion in 'Plesk for Windows - 8.x and Older' started by amram, Jan 22, 2006.

  1. amram

    amram Guest

    0
     
    When I connect to plesk via admin account and try to disable a domain I get this:

    _____________
    Unable to activate/deactivate doamin: Unable to update domain data: Unable to update domain:
    bsdomain: Lock wait timeout exceeded; try restarting transaction..
    ____________

    I get this when disabling most of them not all!
    Also when I connect to the server via RDP and connect to plesk locally from there I can Disable these domains!!

    Please Help!
     
  2. amram

    amram Guest

    0
     
    now there is a domain that gives this error even when I try to disable it locally form server.
     
  3. Gris@

    Gris@ Guest

    0
     
    It seems that you should configure my.ini file of admin's mysql with

    innodb_lock_wait_timeout=200

    parametr. You can configure different values (by default it is 50)
    You should add it to [PleskSQLServer] field and restart Plesk's MySQL.
     
  4. amram

    amram Guest

    0
     
    thank you for the hint Gris. I will do that and will share the results.
    Also I noticed something, I have scheduled statistics.exe to run every hour and it takes about
    10 to 15 minute for more than 500 doamins to complete.
    every time I try to disable a domain during this period I get
    the error and I keep getting this error even after the statistics.exe has finished it's work and
    terminated.
    But if I wait until after the termination of the next scheduled statistics.exe and try again the error
    is gone and these domains get disabled!!!!!
     
  5. xandih

    xandih Guest

    0
     
    humm.. its a good information amram

    So, raise the time betwenn schedule os statistics ;)
    I'll expect the results of the topic...

    A good day for all
     
  6. amram

    amram Guest

    0
     
    changed the innodb_lock_wait_timeout=200 as Gris said but I still get the same error. also rising the time between scheduled statistics.exe will increase the execution duration and increases the chance of getting the error.
    so now each time I want to activate and deactivate a domain have to keep an eye on taskmanager for statistics.exe to avoid getting the error.
    BTW has any one else got this error, or it's just me?
     
Loading...