1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't login to Plesk after update to 8.4

Discussion in 'Plesk for Linux - 8.x and Older' started by wintech2003@, Jul 3, 2008.

  1. wintech2003@

    wintech2003@ Guest

    0
     
    Hello,

    After updating to Plesk 8.4 I get the attached error after putting my login details at the login prompt.

    I had a working 8.3 installation and I used the Updater to update to 8.4.
    Base packages and generally everything installed fine, and I managed to login once into the control panel. When I checked the Updater I saw that the app-vault packages where not updated, and when I tried to reinstall them I got a failure report.
    After that I tried again several times to install the packages, and suddenly I'm unable to login into my Plesk Control Panel.
    I have also attached the autoupdater reports. Plesk-1 is a success report, and Plesk-2a & Plesk 2b are failure reports (it's actually one report but because of the filesize limit of the forum, I had to split it into two files).

    Can anyone help me please? :(
     

    Attached Files:

  2. ib1984

    ib1984 Basic Pleskian

    23
    70%
    Joined:
    Jun 25, 2008
    Messages:
    91
    Likes Received:
    0
    Judging by attached autoinstaller logs, upgrade has been completed fine. However, session cannot be initialized. Check if table psa.sessions exists and has proper structure:

    CREATE TABLE `sessions` (
    `sess_id` varchar(33) character set ascii collate ascii_bin NOT NULL default '',
    `type` smallint(5) unsigned NOT NULL default '0',
    `login` varchar(255) character set utf8 NOT NULL default '',
    `ip_address` varchar(15) character set ascii NOT NULL default '',
    `login_time` datetime NOT NULL default '0000-00-00 00:00:00',
    `click_time` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
    PRIMARY KEY (`sess_id`)
    );

    Also, the problem might be caused by inability for user 'psaadm' to write into directory /usr/local/psa/admin/sessions

    Good luck.
     
  3. Gorka

    Gorka Guest

    0
     
    I have the same issue after the upgrade to 8.4

    Could you please detail the proposed solution further?

    BTW, the sessions directory is writable and I also tried rebooting.

    [SOLVED] Freeing space on disk solved the problem. I had selected appvault during the upgrade, and that really takes lots of disk space.
     
Loading...