1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't login to Root via putty after 8.1 upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by calderwood, Mar 4, 2007.

  1. calderwood

    calderwood Regular Pleskian

    25
     
    Joined:
    May 12, 2006
    Messages:
    103
    Likes Received:
    0
    I just upgraded from 8.0.1 to 8.1 PSA CP and now I can't log into the root as SU. States that I'm not logged in at all, but I am in when I list. Here is the log. I use Putty.

    login as: euroxxx
    euroxxx@68.xxx.xxx.xxx's password:
    Access denied
    euroxxx@68.xxx.xxx.xxx's password:
    Could not chdir to home directory /home/euroxxx: Permission denied
    -bash: /home/euroxxx/.bash_profile: Permission denied
    -bash-2.05b$ ls
    aquota.user boot etc lib mnt root sys var
    backup dev home lost+found opt sbin tmp
    bin dev.tar initrd misc proc selinux usr
    -bash-2.05b$ su -
    Password:
    Unable to open admin password file
    System error 13: Permission denied
    Unable to open admin password file
    System error 13: Permission denied
    -bash-2.05b$ su -
    Password:
    Unable to open admin password file
    System error 13: Permission denied
    Unable to open admin password file
    System error 13: Permission denied
    -bash-2.05b$ ls
    aquota.user boot etc lib mnt root sys var
    backup dev home lost+found opt sbin tmp
    bin dev.tar initrd misc proc selinux usr
    -bash-2.05b$
     
  2. neosfutura

    neosfutura Guest

    0
     
    Hi in the plesk release notes you can read that:

    SSH Terminal may not work properly, failing to log in, when trying to connect to Plesk. For the proper work, modify the SSH Terminal configuration file /etc/ssh/sshd_config as follows:
    In the configuration file, find the strings:
    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication no
    #PermitEmptyPasswords no".

    Remark the string "PasswordAuthentication no" by adding the # sign to the beginning of the string or change the string "PasswordAuthentication no" to "PasswordAuthentication yes".
    Save the file.

    Good Luck ;)
     
  3. calderwood

    calderwood Regular Pleskian

    25
     
    Joined:
    May 12, 2006
    Messages:
    103
    Likes Received:
    0
    No luck

    Had already tried that, but as I don't have true root access, so I don't have permissions to edit the file as it is root /root - I've set up a new server with FC4 and am transferring all of my sites. Also that fixes another problem with having FC2 which is now legacy only and there seems to be no clear upgrade path from FC2 to FC4.

    Thanks for the suggestion.
     
  4. neosfutura

    neosfutura Guest

    0
     
    Ssh not work... ok, can you connect with sftp or scp? to edit the file?
     
  5. jefwic

    jefwic Guest

    0
     
    You don't have shell (non-SSH) access? Ask your datacenter if they can make the change for you from the machine physically.

    That's why I love SoftLayer, shell access via the IPMI over the private backend network.
     
  6. calderwood

    calderwood Regular Pleskian

    25
     
    Joined:
    May 12, 2006
    Messages:
    103
    Likes Received:
    0
    Shell access

    Yes, I have full shell access including SU, but the password access to SU is corrupted and I can't access SU via shell, however I can run a root command thro cron and make stuff happen. I have a serious rights issur that I can't fix.
     
Loading...