1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't send even with POP3 or SMTP authorization on

Discussion in 'Plesk for Linux - 8.x and Older' started by gideonking, Mar 12, 2005.

  1. gideonking

    gideonking Guest

    0
     
    I can't send emails to external servers - configuration info:
    - Plesk 7.5.2 / Redhat 9
    - Mail prefs:
    -- Authorization is required
    -- SMTP checked (also tried with POP3 checked)
    -- White list 127.0.0.0/8, 127.0.0.1/24, 127.0.0.170/24 (170 is the last portion of my server IP address), [server ip]/8
    -- No black list
    -- Require full POP3/IMAP account names required (I've also tried with this option turned off)

    Things I have tested:
    - Open relay allows sending anywhere.
    - Moving /var/qmail/control/rcpthosts out of the way allows sending anywhere
    - I can send emails internally.
    - I can always receive emails OK.
    - I have two domains hosted, and both exhibit the same symptoms.

    I am using a MacOS X mail client, and have tried with no password required and POP3 authentication, and with each of the authentication settings (Password, MD5, Kerberos 4 & 5, NTLM) when using SMTP. All failed to send emails.

    Any suggestions as to what to try next?

    Thanks

    Gideon
     
  2. eWebtricity

    eWebtricity Guest

    0
     
    Watch the maillog during an attempt to send email and see what happens. Should see an error of some kind.
     
  3. gideonking

    gideonking Guest

    0
     
    If I turn Pop on, I get a whole bunch of messages in /var/log/qmail/qmail-pop3d/current saying tcpserver: fatal: unable to bind: address already used.

    If I turn on SMTP and turn off Pop, and try sending with a password, in the qmail-stmpd/current log I get the message:
    status: 1/30
    pid (whatever) from (my ip)
    ok (pid) (server name):(server ip):25 (sender server name):(sender ip)::62233
    end (pid) status 256
    status 0/30


    I don't know whether this is of any help - can someone tell me what to do next?

    Thanks
     
  4. gideonking

    gideonking Guest

    0
     
    Just an update on this - I tried svstat /service/qmail-pop3d and it gave me 0 or 1 second up time and a new pid each time. Should I be worried about this?

    Also, I tried telnet localhost 110, and that worked. I'm not sure whether any of this is related to the issue, as it will send emails when the rcpthosts file has been moved out of the way...
     
Loading...