1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't send/receive mail after 7.5.4

Discussion in 'Plesk for Linux - 8.x and Older' started by hegebutt, Sep 11, 2005.

  1. hegebutt

    hegebutt Guest

    0
     
    I've read all the other posts about qmail misbehaving, and haven't found one that helps me out.

    After I upgraded to 7.5.4, I cannot send or receive mail. Here's what I tried so far:

    1. Tried to telnet to port 25. Connection refused.

    2. Tried stopping qmail in the CP. The CP icons do not show the service as stopped. Tried restart. Still no connection.

    3. Checked ps -ax | grep qmail to see if it was running. Not sure what the result means, but through comparison with results in another post, it seems to be running.

    4. Tried stopping qmail from the command line. Still shows up as running in Plesk.

    5. Tried reinstalling qmail. Still SMTP connection refused. Same problems.

    I'm out of ideas. What else can I try?
     
  2. osilber

    osilber Guest

    0
     
    I had the same the problem after an update to 7.5.4.

    In fact, the XINETD services name were changed from SMTP_PSA to SMTP.PSA.

    Changed it back, it must be SMTP_PSA and SMTPS_PSA (into the folder /etc/xinetd.d).

    Olivier
     
  3. _tek

    _tek Basic Pleskian

    23
    40%
    Joined:
    Feb 7, 2005
    Messages:
    46
    Likes Received:
    0
    same issue different fix

    have to admit i caused this one quite by accident but in the hopes it might help someone else here is what happened.

    trying to resolve the issue of spam on qmail and all of the other issues with qmail like it stopping processing mail intermittently and not running as a service but as a daemon i upgraded/installed xinetd on debian sarge. did not pay attention that qmail is actually not running in xinetd but was being started by inetd.

    While i would prefer that qmail ran all the time as we are sending/recieving a large volume of mail i will have to address that at a later time.

    basically removing xinetd enabled me to restart qmail. i will now have to find a xinetd script for qmail before i can run xinetd.

    this posted caused me to have a BFO (blinding flash of the obvious) about my attempt to upgrade xinetd and made me check what was in it and inetd.conf.

    Hope this helps someone else.
     
Loading...